Don't get complete files on hard drive when downloading real big files

VERIFIED DUPLICATE of bug 114347

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 114347
16 years ago
2 years ago

People

(Reporter: frank carlsson, Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I was trying to download real big files from Oracles website (>500MB).
Everything seems to work just fine, but all I get on my hard drive is files of
the size 198520832 bytes. However, it works just fine when downloading whith
Netscape Communicator 4.78.
(Reporter)

Updated

16 years ago
Target Milestone: --- → mozilla0.9.8
Reporter:
Which build ID ? (Do you mean 0.9.8 [The target milestone is for the developer
and pelase don't touch it])
Can you look if the files are .gz compressed ?
Is you temp directory full ? (mozilla downloads first into the OS TEMP directory
and moves it later to the real directory)

Target Milestone: mozilla0.9.8 → ---
Are the bug files possibly available for testing?
(Reporter)

Comment 3

16 years ago
Sorry, I missed about the milestone builds was for the mozilla developers only.

Well, I guess Matti found the problem. My /tmp catalog is just 184324 kb (swap
partition is much bigger though!). I guess I'll have to repartition my drive :-(

However, it would have been nice to get a message about that the temp directory
is to small, and possibly get a suggestion about action, when trying to download
- or even better, the browser don't use the temp directory and use the target
directory directly under the present condition. I wonder how Netscape 4.78 do
when downloading - it works much better for me :-). Anyway, thanks for your very
fast reply!

Sincerely,
Frank
See bug 27609 for the error message issue (coming soon).

See bug 55690 for the "saving to temp instead of final destination" issues.

*** This bug has been marked as a duplicate of 114347 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
I totally agree with frank, Mozilla shouldn't use the temp directory when
downloading files. It should save to the target directory directly. Many
advanced users, like myself, have a fairly small partition for the OS itself and
other, larger partitions for files such as music, documents, etc. Since the OS
folder by default contains the temp folder, Mozilla should at least have the
option to download files directly to the target destination, instead of placing
it in the temp folder and then move it when the file is downloaded.
v
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.