Closed Bug 1247110 Opened 4 years ago Closed 4 years ago

Synced Tabs Sidebar - keyboard navigation issues

Categories

(Firefox :: Sync, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 48
Tracking Status
firefox47 --- affected
firefox48 --- verified

People

(Reporter: markh, Assigned: eoger)

References

Details

Attachments

(2 files, 2 obsolete files)

2 main issues:

* Open the sidebar - focus is in the search field. Press tab. We expect to see the selection move into the tabs+devices list, but it doesn't - there's no way to select a tab or device using just the keyboard.

* Once you do manage to get an item selected with the mouse, the keyboard *can* be used to navigate - however, if you press <down> when the last item is selected, the selection moves to the first item - ie, the selection "wraps" around. This shouldn't happen.

We decided this should *not* block SyncedTabs riding the trains.
Summary: Keyboard navigation loops + just doesn't work → Synced Tabs Sidebar - keyboard navigation issues
Flags: firefox-backlog+
Priority: -- → P3
Attached patch bug-1247110.patch (obsolete) — Splinter Review
Here's a basic patch
Assignee: nobody → edouard.oger
Status: NEW → ASSIGNED
Attachment #8739610 - Flags: review?(markh)
Attached image syncedtabs-keyboard.gif
This doesn't quite work as expected for me on Windows. The attached .gif shows me pressing Tab from the searchbox, and it appears as though the entire tabs pane gets focus rather than an individial tab or client - note the strange-looking focus line underneath the bottom tab. I then press Shift-tab and focus shifts back to the searchbar. Finally, I press Down-Arrow when that entire pane is selected, and finally the device is selected. So it looks like we need to prevent the pane itself getting focus.
Attachment #8739610 - Flags: review?(markh)
Attached patch bug-1247110.patch (obsolete) — Splinter Review
That will do for now
Attachment #8739610 - Attachment is obsolete: true
Attachment #8741173 - Flags: review?(markh)
Comment on attachment 8741173 [details] [diff] [review]
bug-1247110.patch

This doesn't work at all for me on Windows - when I press Tab while in the searchbox, the focus does leave the searchbox but there's no visual indication of anything else having focus at all (ie, I don't see the outline that was in the gif you showed me).

I guess that's due to:

+.item-title:focus {
+  outline: none;
+}
+

although you obviously added that for some reason?
Attachment #8741173 - Flags: review?(markh) → review-
I added the rule for consistency with the other sidebars, but I don't mind removing it.
Attachment #8741173 - Attachment is obsolete: true
Attachment #8741414 - Flags: review?(markh)
Comment on attachment 8741414 [details] [diff] [review]
bug-1247110.patch

Review of attachment 8741414 [details] [diff] [review]:
-----------------------------------------------------------------

cool, thanks!
Attachment #8741414 - Flags: review?(markh) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/0260dd297a25
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
I have reproduced this bug with Nightly 47.0a1(2016-02-09) with instruction from comment 0 and Linux x86.     

Verified as fixed with Latest Beta 48.0b7(Build ID:20160711002726)
User Agent:Mozilla/5.0 (X11; Linux i686; rv:48.0) Gecko/20100101 Firefox/48.0

[bugday-20160713]
I have reproduced this bug with Firefox Nightly 47.0a1 (Build Id : 20160209030347) on Windows 7(64-bit) with the instructions from comment 0.

Verified as fixed with Latest Firefox Beta 48.0b7 (Build ID : 20160711002726)

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

[bugday-20160713]
As it is verified on both Linux (Comment 9) and windows (Comment 10), Marking it as verified!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.