Closed Bug 1247217 Opened 5 years ago Closed 5 years ago

[CID 749520] Free a pointer

Categories

(Toolkit :: Application Update, defect)

47 Branch
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: paul.bignier, Assigned: paul.bignier)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20160127060627
Attachment #8717842 - Flags: review?(netzen)
Assignee: nobody → paul.bignier
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Duplicate of this bug: 1247922
Attachment #8717842 - Flags: review?(netzen) → review?(robert.strong.bugs)
Comment on attachment 8717842 [details] [diff] [review]
0001-CID-749520-Free-a-pointer.patch

Please also add free(mbuf) for the other early return slightly below in the same function

http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/update/updater/updater.cpp#3858

I'll r+ it with that and if you want I can land it for you as well.
Attachment #8717842 - Flags: review?(robert.strong.bugs) → review-
> I'll r+ it with that and if you want I can land it for you as well.

Yes please :)
Attachment #8717842 - Attachment is obsolete: true
Attachment #8739868 - Flags: review?(robert.strong.bugs)
Attachment #8739868 - Flags: review?(robert.strong.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/ea7e3da670d6
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
You need to log in before you can comment on or make changes to this bug.