Closed Bug 1247271 Opened 4 years ago Closed 4 years ago

Size format not saved when writing a new mail using gmail

Categories

(Core :: General, defect)

All
Unspecified
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox44 --- affected
firefox45 --- affected
firefox46 --- affected
firefox47 --- affected

People

(Reporter: bogdan_maris, Unassigned)

Details

Attachments

(1 file)

[Affected versions]:
- Firefox 44.0.2 build 2
- Firefox 45beta4
- Latest Developer Edition 46.0a2
- Latest Nightly 47.0a1

[Affected platforms]:
- Mac OS X 10.10.5
- Ubuntu 14.04 32-bit

[Steps to reproduce]:
1. Visit https://mail.google.com/
2. Click 'Compose'
3. Click 'A' (Formatting options) button
4. Click 'tT' (Size) button
5. Select a size
6. Click the type field
7. Type something
8. Repeat steps 4-7 selecting different sizes

[Expected result]:
- Selected size is saved and used when typing.

[Actual result]:
- No size is selected if clicking on type field.

[Regression range]:
- This is not a recent regression. I used mozregression though but the good builds were unusable so I called them good.

Last good revision: 48502b61a63e (2012-10-23)
First bad revision: 93cc1ee94291 (2012-10-24)
Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=48502b61a63e&tochange=93cc1ee94291

[Additional notes]:
- This is not reproducible on Windows 10 32-bit, Windows 7 64-bit.
- If the used does not click the type field (he doesnt have to, because the cursor is already there.
- Reproduced on Chrome as well but very intermittently.
- Screenscast showing the issue attached.
- I used other email services (Yahoo, Outlook) and I did not reproduce there. Only gmail is affected.
This needs triage to pick a correct component, but Fx::General is definitely wrong.
Component: General → Untriaged
Component: Untriaged → Layout: Text
Product: Firefox → Core
I can reproduce this problem with Fx45.0 in Lubuntu 14.04.4 LTS, WFM in Fx46.0b11 & 44.0.2 on Win10. Obviously it's not a layout problem, like a interoperability issue. I see this font size option has been unchecked when the problem occurred, as well as no error message in Web Console.
OS: All → Unspecified
Component: Layout: Text → Untriaged
(In reply to YF (Yang) from comment #2)
> I can reproduce this problem with Fx45.0 in Lubuntu 14.04.4 LTS, WFM in
> Fx46.0b11 & 44.0.2 on Win10. Obviously it's not a layout problem, like a
> interoperability issue. I see this font size option has been unchecked when
> the problem occurred, as well as no error message in Web Console.

*Removed the "Obviously", do not rule out this possibility for particular case.
The issue is no longer reproducible on the latest Firefox release (47.0) and the latest Nightly (50.0a1, Build ID 20160615030209) on Ubuntu 14.04 x64 and Mac OS 10.11.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Moving from Core::Untriaged to Core::General https://bugzilla.mozilla.org/show_bug.cgi?id=1407598
Component: Untriaged → General
You need to log in before you can comment on or make changes to this bug.