Push maxImageSize for PDF.js

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: gerard-majax, Assigned: gerard-majax)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
I have often failed to display images in some PDFs when making use of them on my Z3c KK.

Most of the time, Pdf.JS stopped because the maxImageSize limit was defined to 1MB. For example, one PDF containing a scan of my payroll would have an embedded image of ~8.5MB.

I propose we push the limit to 20MB, hard coded.
Created attachment 8717898 [details] [review]
[gaia] lissyx:bug1247274 > mozilla-b2g:master
(Assignee)

Comment 2

3 years ago
This was also being hit with the electronic tickets from CGR.fr (no picture)
(Assignee)

Updated

3 years ago
Attachment #8717898 - Flags: review?(fabrice)
Attachment #8717898 - Flags: review?(fabrice) → review+
(Assignee)

Comment 3

3 years ago
https://github.com/mozilla-b2g/gaia/commit/4051091a37075272cd3e6bbdcee0a979340cfa72
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1217724
You need to log in before you can comment on or make changes to this bug.