If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Persona] Unable to verify Persona login using Firefox Browser

RESOLVED FIXED

Status

Cloud Services
Server: Identity
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: liz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8718048 [details]
personapic.PNG

Firefox 44.0.1 fails - Error message when trying to log into either air.mozilla.org or moderator tool. This works using Chrome.

Attached is a screenshot of the error console. We tried turning tracking protection off but that didn't seem to fix the issue.
(Reporter)

Comment 1

2 years ago
Created attachment 8718056 [details]
Can't Verify message.PNG

Here's a screenshot of the error message

Updated

2 years ago
Component: General → Untriaged

Updated

2 years ago
Component: Untriaged → air.mozilla.com
Product: Firefox → Websites
(Reporter)

Comment 2

2 years ago
I just discovered that I get the same can't verify message on mozillians.org.
(Reporter)

Comment 3

2 years ago
Hi. I'm still having this problem. I can't log into Air Mozilla, the Moderator Tool, or mozillians.org using Firefox, so it seems like a Persona related issue. I can log into all 3 services in Chrome. It seems unlikely I'm the only one. If someone could figure out what's going on, I'd really appreciate it. Thanks.

Updated

2 years ago
Component: air.mozilla.com → Server: Identity
Product: Websites → Cloud Services
I'm not able to repro on latest Firefox release, so I wonder if it's something specific to your profile.  :loz, can you please check whether you're able to login using a fresh Firefox profile?
Flags: needinfo?(liz)
(Reporter)

Comment 5

2 years ago
Thanks. Yes, I can log in with a new profile. How can I figure out what in my regular profile is causing the problem?
Flags: needinfo?(liz)
My first guess would be a problem with localStorage or cookies.  If you visit https://login.persona.org and open the debug javascript console, can you type in "localStorage" and successfully view the data that it's storing in your profile?
(Reporter)

Comment 7

2 years ago
Hi Ryan. I'm not very familiar with using a debugger. I went to https://login.persona.org and then to Tools => Web Developer => Debugger. Was that the right thing to do? A section popped up at the bottom with a lot of HTML code (at least I think that's what it is). I put localStorage in the search box, but that didn't seem to change the code that was displayed. Am I doing something wrong? Thanks.
Created attachment 8736983 [details]
Screen Shot 2016-04-01 at 09.54.58.png

Sorry, I should have been more precise:

* Visit https://login.persona.org
* Open Tools => Web Developer => Web Console
* Select the "Console" tab if it's not selected by default
* Type "localStorage" into the prompt there and hit enter

For me it looks like the attached screenshot.
(Reporter)

Comment 9

2 years ago
Thanks. Here's what showed up:

Storage { storageCheck: "true", returnTo: "null", usersComputer: "{"1163407":{"state":"confirmed","up…", emailToUserID: "{"ecompton@mozilla.com":1163407,"li…", main_site: "{}", siteInfo: "{}", stagedOnBehalfOf: "null", interaction_data: "{}", emails: "{}", managePage: "{}" }
Thanks, that looks like it was able to access the storage correctly.  I'm unfortunately short on other things to suggest.  Two more general things you could try:

* Start in "Safe Mode" to see if it's bad interaction with some addon or similar [1]
* Do a profile refresh to clear out any weird state that's in the profile [2]

[1] https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
[2] https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings
(Reporter)

Comment 11

2 years ago
In case this comes up with anyone else, the way I was able to fix the problem was to change, under Privacy Preferences, "Accept third-party cookies" from "Never" to "From Visited."
Thanks Liz, I will try to remember this if similar problems come up again in the future.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.