File uploads not working on Figma due to missing filename

RESOLVED FIXED in Firefox 46

Status

()

Core
DOM
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Dolske, Assigned: baku)

Tracking

({regression})

46 Branch
mozilla47
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 unaffected, firefox46+ fixed, firefox47+ fixed, firefox48 fixed)

Details

(Whiteboard: dom-triaged)

(Reporter)

Description

2 years ago
(Condensed from email)

Verdi reports that Figma (https://www.figma.com/) is not working on Firefox Nightly, but is in Firefox Release. File uploads are failing due to a missing filename:

From a Figma developer: "I have found the source of the error.  We submit uploads from the client using multipart/form-data.  This includes multiple files in the body, where we set the filename using the "content-disposition" header of the subpart.  It appears that Firefox Nightly is using empty-string for the filename instead of the filename we picked.  Our server does a sanity check on the value, and this is failing the upload.  We can push a fix to the server for this issue, but I fear is may be a bug in the Firefox Nightly build."


Chrome's subpart header:
------WebKitFormBoundaryAJ2J75F4BgRkhNsl
Content-Disposition: form-data; name="canvas"; filename="blob"
Content-Type: application/x-figma

Firefox 42.0 subpart header:
-----------------------------9470810914431048731937796362
Content-Disposition: form-data; name="thumbnail"; filename="blob"
Content-Type: image/png

Firefox Nightly's subpart header:
-----------------------------14152053321974624399299993255
Content-Disposition: form-data; name="thumbnail"; filename=""
Content-Type: image/png
(Reporter)

Comment 1

2 years ago
I found the similar bug 649150 while looking for this in Bugzilla, fixed way back in Firefox 7. The testcase there (attachment 526515 [details]) is regressed for me in Nightly. When I upload a file, and look at the HTTP request in devtools, I see the empty filename="".

That bug added a test, and I see that we recently reverted that test in bug 1241171 as a deliberate change.

Filing this since it had webcompat impact as feared, but sounds like the Figma folks are willing to fix their site.

Comment 2

2 years ago
There has been changes to filename handling, but I've got lost in all those changes.
(Some of the changes include also changes to specifications.)
Sounds like we must back out something.
Flags: needinfo?(amarchesini)

Comment 3

2 years ago
[Tracking Requested - why for this release]:
Bad regression. Caused by bug 1241171 or other related bug.
tracking-firefox46: --- → ?
tracking-firefox47: --- → ?

Updated

2 years ago
Whiteboard: dom-triaged
Tracking, regression in 46+ probably from bug 1241171
status-firefox45: --- → unaffected
status-firefox46: --- → affected
status-firefox47: --- → affected
tracking-firefox46: ? → +
tracking-firefox47: ? → +
baku: what kind of QE or testing help would you like here? 
andrei: can someone from your team help out?
Flags: needinfo?(andrei.vaida)
Maybe this is (or will soon) be fixed by the patch in bug 1246375.  I think that may be what needs a test.
Dolske pointed out that it may make more sense for mverdi to test this.
Flags: needinfo?(andrei.vaida) → needinfo?(mverdi)

Comment 8

2 years ago
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #7)
> Dolske pointed out that it may make more sense for mverdi to test this.

I can do that.
Flags: needinfo?(mverdi)

Comment 9

2 years ago
Thanks for having a look at this issue.  Please let me know if there's anything else we can provide!
-Team Figma
John, want to test the latest Nightly (http://nightly.mozilla.org/) to verify bug 1246375 fixed also this.
Flags: needinfo?(smartj)

Comment 11

2 years ago
I just tested this and it now works as expected. I tested with:
Firefox 47.0a1
Build ID 20160219030248
Windows_NT 10.0 x86-64
(Assignee)

Updated

2 years ago
Flags: needinfo?(amarchesini)
(In reply to Verdi [:verdi] from comment #11)
> I just tested this and it now works as expected. I tested with:
> Firefox 47.0a1
> Build ID 20160219030248
> Windows_NT 10.0 x86-64

I can confirm this in nightly, too.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(smartj)
Resolution: --- → FIXED
From comment 11 and comment 12, marking fixed, and I think it is fixed in 46 as well from bug 1246375.
status-firefox46: affected → fixed
status-firefox47: affected → fixed
status-firefox48: --- → fixed
Assignee: nobody → amarchesini
Target Milestone: --- → mozilla47
Version: unspecified → 46 Branch
You need to log in before you can comment on or make changes to this bug.