Autocomplete CSS rules for justify-content and align-items

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: CSS Rules Inspector
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: David Bruant, Unassigned)

Tracking

46 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Experienced in Firefox Dev Edition 46.0a2 (2016-02-10) (but has been around for much longer, I was just lazy to report. Sorry :-/)


# Steps to reproduce

1) open a web page
2) open inspector
3) add a CSS rule to any element. Type 'justify-content' (same for 'align-items') for the rule name.
(value autocomplete opens)


# Expected behavior

autocomplete presents useful values (center, flex-start, space-around, etc.)


# Actual behavior

autocomplete only proposes 'inherit', 'initial', 'unset'
Thanks for filing. I had seen this too and didn't file either.

This comes from inIDOMUtils.getCSSValuesForProperty:
https://dxr.mozilla.org/mozilla-central/source/layout/inspector/inIDOMUtils.idl#91

This is the helper we use in inplace-editor.js to get the list of suggestions.
To confirm, you can open scratchpad (Shift-F4), then switch it to "browser" environment, and execute the following code:

var util = Cc["@mozilla.org/inspector/dom-utils;1"].getService(Ci.inIDOMUtils);
util.getCSSValuesForProperty("justify-content");

Tom: could you advise how one might be able to fix this, so that we have everything in this bug if someone wants to fix this?
Component: Developer Tools: Inspector → Developer Tools: CSS Rules Inspector
Flags: needinfo?(ttromey)

Comment 2

2 years ago
This works in my build.  Here's cut and paste from the scratchpad, which put the result
into a comment:


var util = Cc["@mozilla.org/inspector/dom-utils;1"].getService(Ci.inIDOMUtils);
util.getCSSValuesForProperty("justify-content");

/*
baseline,center,end,flex-end,flex-start,inherit,initial,last-baseline,left,normal,right,space-around,space-between,space-evenly,start,stretch,unset
*/


Completion of justify-content values in the rule view works for me as well.

My build is based on a recent fx-team.
Flags: needinfo?(ttromey)
Oh you're right. I tried in FF46 originally, were the bug was reported. But it appears to have been fixed in FF47.
So, David, looks like this works and we'll just to wait for 3~4 weeks to see it in Dev Edition.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

2 years ago
(In reply to Patrick Brosset [:pbrosset] [:pbro] from comment #3)
> Oh you're right. I tried in FF46 originally, were the bug was reported. But
> it appears to have been fixed in FF47.
I can see that in the latest nightly indeed.

> So, David, looks like this works and we'll just to wait for 3~4 weeks to see
> it in Dev Edition.
Excellent! Thanks!
You need to log in before you can comment on or make changes to this bug.