SSL client doing client auth crashes in cert code

VERIFIED FIXED in 3.4

Status

NSS
Libraries
P1
normal
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Julien Pierre, Assigned: Wan-Teh Chang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
(dbx) where |more                                                               
current thread: t@34                                                            
=>[1] __CERT_NewTempCertificate(handle = 0x85788, derCert = 0xfddd10f4, nickname
 = (nil), isperm = 0, copyDER = 1), line 218 in "stanpcertdb.c"                 
  [2] ssl3_HandleCertificate(ss = 0x5f0c68, b = 0x2f19b7 "", length = 561U), lin
e 6491 in "ssl3con.c"                                                           
  [3] ssl3_HandleHandshakeMessage(ss = 0x5f0c68, b = 0x2f179e "", length = 1098U
), line 7157 in "ssl3con.c"                                                     
  [4] ssl3_HandleHandshake(ss = 0x5f0c68, origBuf = 0x15a30c), line 7273 in "ssl
3con.c"                                                                         
  [5] ssl3_HandleRecord(ss = 0x5f0c68, cText = 0xfddd13bc, databuf = 0x15a30c), 
line 7538 in "ssl3con.c"                                                        
  [6] ssl3_GatherCompleteHandshake(ss = 0x5f0c68, flags = 0), line 204 in "ssl3g
thr.c"                                                                          
  [7] ssl_GatherRecord1stHandshake(ss = 0x5f0c68), line 1300 in "sslcon.c"      
  [8] ssl_Do1stHandshake(ss = 0x5f0c68), line 156 in "sslsecur.c"               
  [9] ssl_SecureSend(ss = 0x5f0c68, buf = 0xb51e0 "GET /index.html HTTP/1.0\n\n"
, len = 26, flags = 0), line 1100 in "sslsecur.c"                               
  [10] ssl_Send(fd = 0x12e0e8, buf = 0xb51e0, len = 26, flags = 0, timeout = 360
000000U), line 1212 in "sslsock.c"                                              
  [11] PR_Send(0x12e0e8, 0xb51e0, 0x1a, 0x0, 0x15752a00, 0xfddd1700), at 0xfee1f
1c0                                                                             
  [12] SunRequest::send(this = 0x5ade38, sock = 0x12e0e8), line 308 in "request.
(Reporter)

Comment 1

16 years ago
This occurred in a stress test. The client died after about 18 hours.
I was running an NSS build from thursday night. Will restart with the latest tip.
Priority: -- → P1
Target Milestone: --- → 3.4
(Reporter)

Comment 2

16 years ago
I have not reproduced this yet over the past 20 hours.
(Assignee)

Comment 3

16 years ago
We will do more stress testing before NSS 3.4 RTM, with both
strsclnt and the web server GAT client.  If we can't reproduce
this crash, I will mark the bug INVALID.
(Reporter)

Comment 4

16 years ago
I have not been able to reproduce this in my week-end client auth stress test.
Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

16 years ago
Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.