Skipping "Start browsing" link from welcome screen will display later about:home with focus on URL Bar on first attempt to open a link from Settings

RESOLVED DUPLICATE of bug 1208138

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1208138
2 years ago
2 years ago

People

(Reporter: TeoVermesan, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox44 affected, firefox45 affected, firefox46 affected, firefox47 affected, fennec46+)

Details

(Reporter)

Description

2 years ago
Steps to reproduce:
1. Launch Firefox with a clean profile
2. Go to Settings -> Sync and login with valid credentials;
3. Go to android settings and clear data but don't remove the sync account
4. Reopen Firefox
5. Skip the welcome screen(don't click "start browsing")
6. Go to menu -> settings-> click on your account
7. Click your account under "Signed in as"

Actual results:
- About:home is displayed with focus in the URL Bar
- Tapping the "x" button will open a new tab with "Sign in to continue" page

Expected results:
- "Sign in to continue" page should be displayed after step 7

Note:
- also reproducible if after step 5, you go to menu -> settings-> click on your account and tap "Terms of Service" link. 
- please take a look at the video: https://www.youtube.com/watch?v=yUxNaQGosvk&feature=youtu.be

Updated

2 years ago
tracking-fennec: --- → ?
Flags: needinfo?(liuche)
I just landed bug 1208138 which hides first run when you open settings (as well as when any web pages are loaded), so it should no longer be possible to reach this state. I also tried repro-ing this by clicking on the "data notification" that we show the first time a user starts up Firefox and opening a "learn more" link, but this path is no longer a problem.

Thanks for filing, Teodora! Please reopen if you find you can still repro this even with the new changes.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(liuche)
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1208138
tracking-fennec: ? → 46+
You need to log in before you can comment on or make changes to this bug.