Type-check the Cycle Collector macros

RESOLVED DUPLICATE of bug 1247679

Status

()

Core
DOM: Core & HTML
RESOLVED DUPLICATE of bug 1247679
2 years ago
2 years ago

People

(Reporter: terrence, Assigned: terrence)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox47 affected)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
In bug 1247515, Andrew suggested that we could add a shim function to check the type. We don't even need to go that far, however. With C++11 decltype and mozilla::IsSame, we can just compare the actual type against the expected type.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1247679
(Assignee)

Comment 2

2 years ago
Created attachment 8718438 [details] [diff] [review]
type_check_CC_macros-v0.diff

For future reference, the attached built for me locally.
You need to log in before you can comment on or make changes to this bug.