Autophone - Unit Tests failing due to rm failed for /data/tombstones, No such file or directory

RESOLVED DUPLICATE of bug 1247639

Status

RESOLVED DUPLICATE of bug 1247639
3 years ago
3 years ago

People

(Reporter: bc, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox47 fixed)

Details

(Reporter)

Description

3 years ago
Beginning with https://hg.mozilla.org/integration/mozilla-inbound/rev/0ca917b25c1b

rca (and presumably
Checking for orphan ssltunnel processes...
Checking for orphan xpcshell processes...
Traceback (most recent call last):
  File "mochitest/runrobocop.py", line 539, in run_test_harness
    runResult = robocop.runTests()
  File "mochitest/runrobocop.py", line 472, in runTests
    self.startup()
  File "mochitest/runrobocop.py", line 92, in startup
    self.auto.deleteTombstones()
  File "/mozilla/autophone/autophone/builds/aHR0cDovL2FyY2hpdmUubW96aWxsYS5vcmcvcHViL21vYmlsZS90aW5kZXJib3gtYnVpbGRzL21vemlsbGEtaW5ib3VuZC1hbmRyb2lkLWFwaS0xNS8xNDU1MTg1ODUxL2Zlbm5lYy00Ny4wYTEuZW4tVVMuYW5kcm9pZC1hcm0uYXBr/tests/mochitest/remoteautomation.py", line 160, in deleteTombstones
    timeout=DeviceManager.short_timeout)
  File "/mozilla/autophone/autophone/builds/aHR0cDovL2FyY2hpdmUubW96aWxsYS5vcmcvcHViL21vYmlsZS90aW5kZXJib3gtYnVpbGRzL21vemlsbGEtaW5ib3VuZC1hbmRyb2lkLWFwaS0xNS8xNDU1MTg1ODUxL2Zlbm5lYy00Ny4wYTEuZW4tVVMuYW5kcm9pZC1hcm0uYXBr/tests/mochitest/devicemanager.py", line 405, in shellCheckOutput
    raise DMError("Non-zero return code for command: %s (output: '%s', retval: '%s')" % (cmd, output, retval))
DMError: Non-zero return code for command: ['rm', '-r', '/data/tombstones'] (output: 'rm failed for /data/tombstones, No such file or directory
2', retval: '255')
0 ERROR runrobocop.py | Received unexpected exception while running tests
1 ERROR Got suite_end message before suite_start. Logged with data: {}

This should have been caught at

https://dxr.mozilla.org/mozilla-central/source/build/mobile/remoteautomation.py#160

The autophone hosts had mozdevice 0.47 installed. I upgraded to 0.48 and am restarting the servers. If that doesn't fix the issue, I'm not sure what the cause of the failure to be caught in the except DMError is.

Updated

3 years ago
See Also: → bug 1247639
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1247639
(Reporter)

Comment 2

3 years ago
Heh. I just assumed it was my problem. Restarted at ~13:30
status-firefox47: affected → fixed
You need to log in before you can comment on or make changes to this bug.