Disable the 64-bit build plugin whitelist

UNCONFIRMED
Unassigned

Status

UNCONFIRMED
3 years ago
3 years ago

People

(Reporter: rexyrexy2, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
It would be nice if the new 64-bit plugin whitelist could be disabled in SeaMonkey. There are no official 64-bit builds, but it would be nice if unofficial 64-bit SeaMonkey builds did not have this unnecessary restriction on them.
(Reporter)

Comment 1

3 years ago
(this whitelist is *HARDCODED*, it cannot be disabled through about:config as it currently stands.)
There are semi-official L64 builds at ftp.m.o when the builders work, there are fully official Universal 32/64 bit builds for the Mac (again, when the builders work), and Adrian Kalla publishes W64 and L64 builds with Lightning when he thinks of it (unofficial, but from official sources). IOW, 64-bit builds exist (though not fully official) for all three Tier1 platforms.

AFAICT, I have the following in ~/.mozilla/plugins -> /usr/lib64/browser-plugins :
1) javaplugin.so -> /etc/alternatives/javaplugin -> /usr/lib64/java-1_8_0-openjdk-plugin/lib/IcedTeaPlugin.so
2) libflashplayer.so
3) libgnome-shell-browser-plugin.so
4) libnptc.13.1.so
5) librythmbox-itms-detection-plugin.so
6) packagekit-plugin.so
7) skypebuttons.so

They all appear in about:addons and about:plugins except the cryptically-named #4.
You need to log in before you can comment on or make changes to this bug.