If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Sorting by "Version" gives confusing minor-version order

RESOLVED FIXED

Status

Socorro
Webapp
RESOLVED FIXED
2 years ago
10 months ago

People

(Reporter: gerald, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
E.g.:
https://crash-stats.mozilla.com/signature/?date=%3E%3D2016-02-10&signature=mp4_demuxer%3A%3AMP4Metadata%3A%3AGetNumberTracks&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&page=1#reports

Click on the "Version" column header, so that versions are sorted from high to low.
I'm seeing the following order:
45.0b3, 45.0b3, 45.0b4, 45.0b4, 45.0b4, 45.0b3, 45.0b3, 45.0b4, 45.0b4, 45.0b4, 45.0b4, 44.0.1, 44.0, 44.0.1, 44.0, 44.0.1, 44.0, 44.0, 44.0, 44.0.1, 44.0b99, 44.0.1, 43.0.3, 43.0.4

So the major versions (45, 44, 43) are correctly sorted, but the minor version numbers seem almost random.
I would expect a fully sorted list, e.g.: 45.0b4, 45.0b3, 44.0.1, 44.0, 44.0b99, 43.0.4, 43.0.3.

Sorting from low to high also gives confusing results.
We have a long standing bug on this unfortunately. The problem is that that page you showed has 52 Results and only the first 50 are shown per-page. When you click any of the sorting headers it sorts only that first page. What it ought to do is do another server-side query and sort it there. 
In other words, the sorting, today, is done by some jQuery table render plugin and it's clearly not very good.

Adrian, if we had sort done by doing a new server-side query, will it sort correctly in ES?
(In reply to Peter Bengtsson [:peterbe] from comment #1)
> Adrian, if we had sort done by doing a new server-side query, will it sort
> correctly in ES?

Yes, this this for example: https://crash-stats.mozilla.com/api/SuperSearch/?date=%3E=2016-02-10&signature==mp4_demuxer::MP4Metadata::GetNumberTracks&_columns=version&_sort=version

It would require hacking the table sorting to reload the data, which we have done already in the report/list/ page, so it's definitely doable.
(In reply to Adrian Gaudebert [:adrian] from comment #2)
> (In reply to Peter Bengtsson [:peterbe] from comment #1)
> > Adrian, if we had sort done by doing a new server-side query, will it sort
> > correctly in ES?
> 
> Yes, this this for example:
> https://crash-stats.mozilla.com/api/SuperSearch/?date=%3E=2016-02-
> 10&signature==mp4_demuxer::MP4Metadata::
> GetNumberTracks&_columns=version&_sort=version
> 
> It would require hacking the table sorting to reload the data, which we have
> done already in the report/list/ page, so it's definitely doable.

Definitely worth doing in 2016. This is part of that "SuperSearch UX Love" :)
(Reporter)

Comment 4

2 years ago
Thank you Peter&Adrian for looking into it, much appreciated.
In the meantime I can sort by build date (per page), I usually focus on the latest build anyway.
We solved this but didn't complete the bug-duplication resolution.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.