Theme catastrophe blocks access to Preferences / Themes

RESOLVED DUPLICATE of bug 121860

Status

SeaMonkey
Themes
--
critical
RESOLVED DUPLICATE of bug 121860
16 years ago
10 years ago

People

(Reporter: Ben Tremblay, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Opening PrefTheme Crashes Moz

Win95 2002012803 TalkBack 2762672E
1) installed new theme (LittleMoziila), found that
2) could not restore to Classic, but found others ok (Eskimo)
3) Hoping to restore Classic as default, uninstalled Eskimo while selected
4) fascinated by wierd combination 90% LittleMoz, 10% Classic *ick*
5) deleted all and re-installed: Moz crashes opening PrefThemes.

Comment 1

16 years ago
Nagging at Stephen again... TB2762672E ?

Severity: normal → critical
(Reporter)

Comment 2

16 years ago
1) I added a theme from 
http://www.informatik.uni-oldenburg.de/~arador/mozilla/themes.htm
and re-started cold. No change *crash not sent*

2) I added a theme from that site again, this time with "Use this theme" 
selected. No effect. Re-started cold. Theme had not applied. Opened PrefTheme 
and crashed *report sent*

Note: I have done multiple uninstalls, deleted all profiles and registries, 
removed all chrome dirs, all components ... in short, deleted everything except 
setup directory. IMHO new install should have no memory of the previous events.
(Reporter)

Comment 3

16 years ago
Created attachment 68836 [details]
Screenshot of mutt =90%LilMoz 10% Classic

Created a new profile and restored data from step 4 ... mutt skin is in place;
no PrefThemes access.

Comment 4

16 years ago
Please file only one bug per bug-report.
Let's make the crash the issue here. Theme mixes is a known issue.

Comment 5

16 years ago
Stephen: TB 2762672E ?
Talkback isn't bringing up anything for that ID, or anything more recent than
last month for Ben's email address...
(Reporter)

Comment 7

16 years ago
1) Themes remain accessible though only via View menu.

2) stephend: TB2760148K 2760892W 2763336Q 2762672E 2763174W 2763648Z (Sure wish 
there was copy/paste from TB)

3) If you can suggest something I haven't already deleted, I'll back things up 
in order to compare. I am unable to restore function; evidently something is 
hidden.

nsBlockBandData::Init
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockBandData.cpp, line 72]
nsBlockReflowState::nsBlockReflowState
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowState.cpp, line 148]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 735]
nsBoxToBlockAdaptor::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 846]
nsBoxToBlockAdaptor::RefreshSizeCache
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 366]
nsBoxToBlockAdaptor::GetAscent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 573]
nsSprocketLayout::GetAscent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 1521]
nsContainerBox::GetAscent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 595]
nsBoxFrame::GetAscent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1091]
nsSprocketLayout::GetAscent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 1521]
nsContainerBox::GetAscent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 595]
nsBoxFrame::GetAscent
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1091]
nsSprocketLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsSprocketLayout.cpp, line 245]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 612]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1198]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 1052]
nsStackLayout::Layout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsStackLayout.cpp, line 331]
nsContainerBox::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 612]
nsBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1198]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 1052]
nsBoxFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 991]
nsRootBoxFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsRootBoxFrame.cpp, line 243]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 776]
ViewportFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 574]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2674]
nsXULDocument::StartLayout
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 4407]
nsXULDocument::ResumeWalk
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 5946]
nsXULDocument::OnStreamComplete
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 6164]
nsStreamLoader::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsStreamLoader.cpp, line 163]
nsJARChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\jar\src\nsJARChannel.cpp, line 614]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsRequestObserverProxy.cpp, line 213]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
KERNEL32.DLL + 0x22894 (0xbff92894)
0x00648c18 

Comment 9

16 years ago
Dup of bug 121860.
The fix for this is was in builds from the 29th. onwards - one day later than
reporter's build.

*** This bug has been marked as a duplicate of 121860 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

16 years ago
Problem cleared with 2002020803
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.