crash in mozilla::MediaSourceDecoder::GetBuffered

RESOLVED DUPLICATE of bug 1245463

Status

()

--
critical
RESOLVED DUPLICATE of bug 1245463
3 years ago
3 years ago

People

(Reporter: philipp, Assigned: jya)

Tracking

({crash})

45 Branch
Unspecified
Windows NT
crash
Points:
---

Firefox Tracking Flags

(firefox45- affected, firefox46 affected, firefox47 affected)

Details

(crash signature)

(Reporter)

Description

3 years ago
[Tracking Requested - why for this release]:

This bug was filed from the Socorro interface and is 
report bp-bd2af80d-e4e2-43ed-9679-4d46b2160106.
=============================================================
Crashing Thread (0)
Frame 	Module 	Signature 	Source
0 	xul.dll 	mozilla::MediaSourceDecoder::GetBuffered() 	dom/media/mediasource/MediaSourceDecoder.cpp
1 	xul.dll 	mozilla::MediaSourceDecoder::NextFrameBufferedStatus() 	dom/media/mediasource/MediaSourceDecoder.cpp
2 	xul.dll 	mozilla::dom::HTMLMediaElement::UpdateReadyStateInternal() 	dom/html/HTMLMediaElement.cpp
3 	xul.dll 	mozilla::MediaDecoder::UpdateReadyState() 	dom/media/MediaDecoder.h
4 	xul.dll 	mozilla::WatchManager<mozilla::MediaDecoder>::PerCallbackWatcher::DoNotify() 	xpcom/threads/StateWatching.h
5 	xul.dll 	nsRunnableMethodImpl<void ( mozilla::WMFMediaDataDecoder::*)(void), 1>::Run() 	xpcom/glue/nsThreadUtils.h
6 	xul.dll 	mozilla::AutoTaskDispatcher::DrainDirectTasks() 	xpcom/threads/TaskDispatcher.h
7 	xul.dll 	mozilla::XPCOMThreadWrapper::FireTailDispatcher() 	xpcom/threads/AbstractThread.cpp
8 	xul.dll 	nsRunnableMethodImpl<void ( mozilla::WMFMediaDataDecoder::*)(void), 1>::Run() 	xpcom/glue/nsThreadUtils.h
9 	xul.dll 	mozilla::CycleCollectedJSRuntime::ProcessStableStateQueue() 	xpcom/base/CycleCollectedJSRuntime.cpp
10 	xul.dll 	XPCJSRuntime::AfterProcessTask(unsigned int) 	js/xpconnect/src/XPCJSRuntime.cpp
11 	xul.dll 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
12 	xul.dll 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
13 	xul.dll 	MessageLoop::RunHandler() 	ipc/chromium/src/base/message_loop.cc
14 	xul.dll 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
15 	xul.dll 	nsBaseAppShell::Run() 	widget/nsBaseAppShell.cpp
16 	xul.dll 	nsAppShell::Run() 	widget/windows/nsAppShell.cpp
17 	xul.dll 	nsAppStartup::Run() 	toolkit/components/startup/nsAppStartup.cpp
18 	xul.dll 	XREMain::XRE_mainRun() 	toolkit/xre/nsAppRunner.cpp
19 	xul.dll 	XREMain::XRE_main(int, char** const, nsXREAppData const*) 	toolkit/xre/nsAppRunner.cpp
20 	xul.dll 	XRE_main 	toolkit/xre/nsAppRunner.cpp
21 	firefox.exe 	do_main 	browser/app/nsBrowserApp.cpp
22 	firefox.exe 	NS_internal_main(int, char**) 	browser/app/nsBrowserApp.cpp
23 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp
24 	firefox.exe 	__tmainCRTStartup 	f:/dd/vctools/crt/crtw32/startup/crt0.c:255
25 	kernel32.dll 	BaseThreadInitThunk 	
26 	firefox.exe 	fast_error_exit 	f:/dd/vctools/crt/crtw32/startup/crt0.c:322 

this a/v related signature is noticeably increasing/regressing in firefox 45 builds across platforms.
(Assignee)

Comment 1

3 years ago
This bug will be fixed by P1 of bug 1245463
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1245463
(Assignee)

Comment 2

3 years ago
I may take P1 and move it here though...
(Assignee)

Updated

3 years ago
Assignee: nobody → jyavenard
(Assignee)

Updated

3 years ago
Keywords: regression
tracking-firefox45: ? → -
You need to log in before you can comment on or make changes to this bug.