[RFE] Replace minimized download window in Dock with an updating progress bar

RESOLVED DUPLICATE of bug 548763

Status

SeaMonkey
UI Design
--
enhancement
RESOLVED DUPLICATE of bug 548763
16 years ago
5 years ago

People

(Reporter: Andy Lyttle, Assigned: jag (Peter Annema))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.8) Gecko/20020205
BuildID:    2002020516

When downloading a file, it would be nice if you could minimize the download
window to the Dock, and see an updating progress bar in the Dock.  A progress
bar should appear instead of the minimized download window.

Reproducible: Always
Steps to Reproduce:
1. Start downloading a large file
2. Click the yellow - button to minimize the download window
3. Look at the minimized download window in the Dock

Actual Results:  A thumbnail of the download window appears in the Dock.  If you
look closely, you'll notice the tiny progress bar is not updating (see bug 84453).

Expected Results:  Instead of making the thumbnail update, which would really be
too small to be useful, we should just replace the thumbnail with a progress
bar.  Perhaps show the percentage above or below the bar, since Dock icons are
vaguely squarish and progress bars are generally not.

AIM replaces minimized IM windows with the other person's Buddy Icon, so this
sort of thing is certainly possible.

Comment 1

16 years ago
->jag/future
Target Milestone: --- → Future

Comment 2

16 years ago
Sorta looks like a dup of bug 35046.
(Reporter)

Comment 3

16 years ago
Hmm, that'd be good too, but this isn't a dupe.  Bug 35046 is about updating the
title of a download window in the taskbar (which would only affect Mac OS X
during a mouseover, and only while the window is minimized), while this is about
a custom Dock icon, which is kind of an OSX-specific thing (although it'd be
pretty sweet for WindowMaker, I imagine).  Both have the same goal (letting the
user see progress while the window is minimized) but the best way to achieve
that goal varies by platform.

Comment 4

16 years ago
I propose this should be WONTFIX. I don't think it's appropriate to
automatically send a new window to the Dock. Windows should only minimize to the
Dock if the user specifically takes action to do so.

Also, some users don't have the Dock visible at all times, and might not realize
the download was underway without the window (or some sort of Download Manager
window, which has also been proposed elsewhere) visible.
(Reporter)

Comment 5

16 years ago
Perhaps you misunderstood the request - I'm not proposing that download windows
should be automatically minimized.  I'm proposing that when a download window is
minimized to the Dock (because the user has specifically taken action to do so),
a useful progress-bar icon should be displayed, instead of a fuzzy miniature
download window that doesn't convey any useful information. :-)

Comment 6

16 years ago
You're right, I did misunderstand your request. Confirming as an RFE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This looks pretty underdocumented in Carbon.  Here's a mention in passing, anyhow:

http://developer.apple.com/techpubs/macosx/Essentials/AquaHIGuidelines/AHIGDock/Dock_Notifi_on_Behavior.html

In Cocoa, you use setMiniwindowImage, which looks fairly well supported. 
Chimera maybe?
(Reporter)

Comment 8

16 years ago
Roxio Toast adds a progress bar to its application icon in the Dock while
burning and verifying CDs.  Quite a nice feature.  I expect to see other apps
putting progress bars in the Dock as well.  Wish I could help with the coding.

Comment 9

15 years ago
This should be reasonably easy in Camino.

One could make an NSView of width 128 (max width of dock icon) containing an
NSProgressIndicator. It's not too difficult to get that NSView to draw its
contents to an NSImage. Then you call -miniwindowImage, composite with the
NSImage containing the progress indicator, and then -setMiniwindowImage to set it.

For Mozilla/Carbon, you probably want to look here:

http://developer.apple.com/techpubs/macosx/Carbon/HumanInterfaceToolbox/DockManager/Dock_Manager/dockmngr_refchap/FunctionGroupIndex.html

I'd imagine you'd want to use:
OverlayApplicationDockTileImage from here:
http://developer.apple.com/techpubs/macosx/Carbon/HumanInterfaceToolbox/DockManager/Dock_Manager/dockmngr_refchap/

I think you'd call DrawThemeTrack() to draw a progress bar, somehow munge it
into a 128 px wide image as above, then use OverlayApplicationDockTileImage.
Status: NEW → ASSIGNED
Product: Core → Mozilla Application Suite
Assignee: trudelle → jag
Status: ASSIGNED → NEW
QA Contact: bugzilla
Target Milestone: Future → ---

Comment 10

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 11

9 years ago
This bug definitively still applies to current SeaMonkey 2.x nigthly builds.

Tested with
– Build identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.1.2pre) Gecko/20090722 SeaMonkey/2.0b2pre
– Build identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090722 SeaMonkey/2.1a1pre

In the 2.x builds the minimized download windows shows an updating completion percentage in the name on mouse hover but the minimized download windows is still a not updating and too small to be useful thumbnail of the original download window.

Comment 12

8 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 13

5 years ago
Fixed in:
Bug 548763 - Show download progress in app icon in Mac OS X Dock
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 548763
You need to log in before you can comment on or make changes to this bug.