Repeating event with end date not created correctly

RESOLVED DUPLICATE of bug 566149

Status

RESOLVED DUPLICATE of bug 566149
3 years ago
2 years ago

People

(Reporter: rogier, Unassigned)

Tracking

Lightning 4.0.5.2

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160123151951

Steps to reproduce:

Create a new event in Lightning
Set a start date and time
Enter a title
Set custom repeat schedule of more then one day (2 or 3)
Save


Actual results:

Task gets repeated until the end of the month


Expected results:

Task should only have been repeated for the specified number of days

Comment 1

3 years ago
Hi Rogier,
I can't reproduce the issue.
When you write 

> Set custom repeat schedule of more then one day (2 or 3)

what do you mean exactly? Can you specify the settings you select in the Edit Recurrence dialog (for a _custom_ repeating rule)?
What version of Thunderbird and Lightning are you using?
Is the preference calendar.icaljs (Menu Tools > Options > Advanced > General > Config Editor) set to true or false?
Do you have errors in the Error Console (Menu Tools > Error Console)?
Do you use a local calendar or a remote one?
(Reporter)

Comment 2

3 years ago
Created attachment 8719415 [details]
Creating a new custom event in Lightning
(Reporter)

Comment 3

3 years ago
Created attachment 8719416 [details]
Editing the event just created

Note that the end date got repeated for 14 days more then I set it at.
(Reporter)

Comment 4

3 years ago
Hey Decathlon,

See my attachments, hopefully that clears things up.

- Thunderbird: 38.5.1, but the issue has been around for much longer, just didn't get around to reporting it.
- Lightning: 4.0.5.2
- calendar.icaljs: false (default)

Comment 5

3 years ago
(In reply to Rogier from comment #4)
> See my attachments, hopefully that clears things up.

OK, a daily rule, not a "custom" rule. ;)

I've just installed the same versions of TB and LG but I can't reproduce on Win 7.

Could you please report:
- if there are errors related to the event in the Error Console (CTRL + Shift + J).
- if the calendar is local or remote;
- if you have others addons apart from Lightning on your Thunderbird. In this case, try to disable them and restart TB;
- try also to create a new profile and testing form there.

Your OS is Win 10, right?

Updated

3 years ago
Version: unspecified → Lightning 4.0.5.2
Rogier, could you provide the information requested by Decathlon in Comment 5?
Flags: needinfo?(rogier)
(Reporter)

Comment 7

3 years ago
Hello,

I started writing up a reply last week, but then I noticed that with testing while writing I couldn't reproduce it consistently myself either.

In the specific case I encounter this issue regularly is when I create the task at the last week of the month, for the first tuesday/wednesday/thursday (at least two days) the next month. So my best guess now is that it has something to do with the time at which I create the task.

I will try to test it by changing my local date, but need to do that after work hours in the office so it might take a bit before I come back to this issue.

Sorry about that.
(Reporter)

Comment 8

3 years ago
I think I managed to specify the thing that caused it, it only seems to happen when you create a new task by double clicking the events sidebar. I think it's called "Today Pane" officially?

About the other points
1. I get a warning, that's it:
Timestamp: 18-3-2016 15:53:07
Warning: Use of Mutation Events is deprecated. Use MutationObserver instead.
Source File: chrome://calendar/content/calendar-daypicker.xml
Line: 46
2. it's a remote caldav calendar
3. It's a freshly installed thunderbird because I wanted to rule out other issues, no other extensions.
4. See point 3.
Flags: needinfo?(rogier)

Comment 9

3 years ago
By chance, when you create the event, do you change the start date proposed in the datepicker, by increasing it of a few/many days, and then (*after* that) you set the until date?
In this case it would be a consequence of bug 566149.
Can you reproduce the issue when you create the event without touching the start date?

Otherwise it might depend on the caldav server. You should enable the preferences calendar.debug.log and calendar.debug.log.verbose and take a look in the Error Console to see if there are errors or other info when you save the event.

The error "Use of Mutation Events is deprecated" is not related.
Flags: needinfo?(rogier)
(Reporter)

Comment 10

2 years ago
It doesn't happen if I don't change the start date, so it might be the same issue as you mentioned.
(Reporter)

Updated

2 years ago
Flags: needinfo?(rogier)

Comment 11

2 years ago
OK, thanks for the answer.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 566149
You need to log in before you can comment on or make changes to this bug.