If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[PP] compose menus are missing after composing 1st msg that contains an attachment

VERIFIED DUPLICATE of bug 12335

Status

MailNews Core
Composition
P3
blocker
VERIFIED DUPLICATE of bug 12335
18 years ago
8 months ago

People

(Reporter: pmock, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build Date & Platform Bug Found:
 MacOS seamonkey build 1999-08-24-11-m9 installed on PPC 9600/300 OS 8.5.1

Overview Description:
 Apprunner fails to draw the message compose menus on the second compose window
you open up after attaching an file attachment on the first message.  The only
menu displayed is the "Help" menu.  If you try to access the help menu, the
application crashes.

Steps to Reproduce:
1) Start Apprunner
2) Open Messenger
3) Start a new message
   I was using a HTML compose window
4) Address the message to yourself
5) Add a subject title
6) Type a short message in the message body
7) Select the File menu and select attach->web page or attach-> file
8) Type in a web page url or select a file then click OK
9) (optional) Send the message.
   It does not matter if you send the message or not.  The first message is sent
10) Start a new message
    Notice that only the help menu is available
11) Select the help menu
    Apprunner crashes

Actual Results:
 The 2nd compose windows renders except for the menus.  You can send messages
with this compose window but you can not access any of the menus.  If you select
the "Help" menu, the application crashes.

Expected Results:
 The compose window should display all menus and should not crash.

Additional Builds and Platforms Tested On:
 This problem does not occur on Win32 or Linux.  I tried the following builds:
  Win32 seamonkey build 1999-08-24-13-m9
  Linux seamonkey build 1999-08-24-11-m9

Additional Information:
 The attach button on the compose toolbar is still functional.  I can attach
files but without the File menu, I can not access the other attachment options.
(Assignee)

Updated

18 years ago
Severity: normal → blocker
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

18 years ago
another scenario for the menu bug. same as bug 12335


*** This bug has been marked as a duplicate of 12335 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 2

18 years ago
I've gone ahead and raised the othe bug to a blocker status.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.