Clean port of Sony devices based on restructured device repos

RESOLVED FIXED

Status

Firefox OS
GonkIntegration
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: adfad666, Assigned: adfad666)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(18 attachments, 2 obsolete attachments)

60 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
58 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
55 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
57 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
56 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
56 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
58 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
56 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
54 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
58 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
55 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
56 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
56 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
64 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
56 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
50 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
46 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
52 bytes, text/x-github-pull-request
gerard
: review+
Details | Review | Splinter Review
(Assignee)

Description

3 years ago
In cooperation with Sony we completely restructured the device repos. We now have three level dependency [device -> platform -> common] which consolidates a ton of duplicated code from across five platforms.

androidboot.hardware in the kernel cmdline is now the device instead of the platform, which means better compatibility with AOSP. However this is a breaking change; old boot images will NOT boot with new system images (and vice versa).

We are informed that the camera blobs have been calibrated. This means on the next blobzip update we should finally have a camera that takes actual pictures!

I have chosen to do a clean B2G port because the changes are simply too dramatic to even try to do a git merge. Most of what we changed is now in a completely different repo.
(Assignee)

Comment 1

3 years ago
Created attachment 8718968 [details]
Test Manifest

If anyone wishes to test before I create that actual PRs this manifest should work.
(Assignee)

Updated

3 years ago
Flags: needinfo?(lissyx+mozillians)
Thanks, I'll give it a test asap
Assignee: nobody → afarden
Flags: needinfo?(lissyx+mozillians)
(Assignee)

Updated

2 years ago
Attachment #8718968 - Attachment is obsolete: true
(Assignee)

Comment 3

2 years ago
Created attachment 8721467 [details] [review]
Kernel PR
Attachment #8721467 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 4

2 years ago
Created attachment 8721470 [details] [review]
Flamingo PR
Attachment #8721470 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 5

2 years ago
Created attachment 8721472 [details] [review]
Eagle PR
Attachment #8721472 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 6

2 years ago
Created attachment 8721474 [details] [review]
Seagull PR
Attachment #8721474 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 7

2 years ago
Created attachment 8721475 [details] [review]
Yukon PR
Attachment #8721475 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 8

2 years ago
Created attachment 8721476 [details] [review]
Sirius PR
Attachment #8721476 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 9

2 years ago
Created attachment 8721477 [details] [review]
Scorpion PR

This depends on a fork of https://github.com/sonyxperiadev/device-sony-scorpion_windy
Attachment #8721477 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 10

2 years ago
Created attachment 8721478 [details] [review]
Aries PR
Attachment #8721478 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 11

2 years ago
Created attachment 8721480 [details] [review]
Leo PR
Attachment #8721480 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 12

2 years ago
Created attachment 8721481 [details] [review]
Shinano PR
Attachment #8721481 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 13

2 years ago
Created attachment 8721488 [details] [review]
Amami PR
Attachment #8721488 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 14

2 years ago
Created attachment 8721489 [details] [review]
Honami PR
Attachment #8721489 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 15

2 years ago
Created attachment 8721490 [details] [review]
Rhine PR
Attachment #8721490 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 18

2 years ago
Created attachment 8721701 [details] [review]
Scorpion Windy PR
Attachment #8721701 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 19

2 years ago
Created attachment 8721703 [details] [review]
Common PR
Attachment #8721703 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 20

2 years ago
Created attachment 8721704 [details] [review]
macaddrsetup PR
Attachment #8721704 - Flags: review?(lissyx+mozillians)
(Assignee)

Comment 21

2 years ago
Created attachment 8721705 [details] [review]
timekeep PR
Attachment #8721705 - Flags: review?(lissyx+mozillians)
I will test those on the devices I have: Z3 ; Z3c ; Z1c ; M2
I guess we will also need patches for:
 - xml repo manifest changes
 - b2g repo changes (adding scorpion windy)
Flags: needinfo?(afarden)
it boots but I have no wifi working (seems the interface does not even gets up when requested by wpa_supplicant) and I cannot connect data.
Duplicate of this bug: 1240933
(In reply to Alexandre LISSY :gerard-majax from comment #24)
> it boots but I have no wifi working (seems the interface does not even gets
> up when requested by wpa_supplicant) and I cannot connect data.

With updated kernel PR and new repo vendor-qcom-opensource-dataservices I have data and wifi again.
Attachment #8721467 - Flags: review?(lissyx+mozillians) → review+
Comment on attachment 8721478 [details] [review]
Aries PR

There are broken parts in this repo that references Sirius at least
Attachment #8721478 - Flags: review?(lissyx+mozillians)
Attachment #8721481 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721703 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721704 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721705 - Flags: review?(lissyx+mozillians) → review+
If it works well enough on Z3, Z3 Tablet, Z1c and M2 I'll land all those.
Created attachment 8721802 [details]
Manifest update
Attachment #8721802 - Flags: feedback?(afarden)
Attachment #8721475 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721472 - Flags: review?(lissyx+mozillians) → review+
(Assignee)

Comment 30

2 years ago
Comment on attachment 8721802 [details]
Manifest update

You also need the scorpion_windy repo
Attachment #8721802 - Flags: feedback?(afarden)
(Assignee)

Comment 31

2 years ago
Comment on attachment 8721478 [details] [review]
Aries PR

Commits fixed and PR updated
Flags: needinfo?(afarden)
Attachment #8721478 - Flags: review?(lissyx+mozillians)
GSM works but no data signal seems to come on Z1c
Attachment #8721490 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721488 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721470 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721474 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721476 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721489 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721478 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721477 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721480 - Flags: review?(lissyx+mozillians) → review+
Attachment #8721701 - Flags: review?(lissyx+mozillians) → review+
(In reply to Alexandre LISSY :gerard-majax from comment #32)
> GSM works but no data signal seems to come on Z1c

02-22 14:25:10.196   337   760 I Gecko   : RIL Worker: [0] data registration state: 2,,,,0,20,,,,,
02-22 14:25:10.204   337   760 I Gecko   : RIL Worker: [0] voice registration state: 2,,,0,,,,0,,,,,,0,
02-22 14:25:10.554   337   760 I Gecko   : RIL Worker: [0] data registration state: 2,,,,0,20,,,,,
02-22 14:25:10.558   337   760 I Gecko   : RIL Worker: [0] voice registration state: 1,2f46,0090d9c4,3,,,,0,,,,,,0,1c9
02-22 14:25:10.578   337   760 I Gecko   : RIL Worker: [0] voice registration state: 1,2f46,0090d9c4,3,,,,0,,,,,,0,1c9
02-22 14:25:10.581   337   760 I Gecko   : RIL Worker: [0] data registration state: 2,,,,0,20,,,,,
02-22 14:25:11.512   337   760 I Gecko   : RIL Worker: [0] voice registration state: 1,2f46,0090d9c4,3,,,,0,,,,,,0,1c9
02-22 14:25:11.521   337   760 I Gecko   : RIL Worker: [0] data registration state: 2,,,,0,20,,,,,
02-22 14:25:12.639   337   760 I Gecko   : RIL Worker: [0] voice registration state: 1,2f46,0090d9c4,3,,,,0,,,,,,0,1c9
02-22 14:25:12.660   337   760 I Gecko   : RIL Worker: [0] data registration state: 2,,,,0,20,,,,,
02-22 14:25:12.945   337   760 I Gecko   : RIL Worker: [0] data registration state: 2,,,,0,20,,,,,
02-22 14:25:12.952   337   760 I Gecko   : RIL Worker: [0] voice registration state: 1,2f46,0090d9c4,3,,,,0,,,,,,0,1c9
02-22 14:25:13.608   337   760 I Gecko   : RIL Worker: [0] voice registration state: 1,2f46,0090d9c4,3,,,,0,,,,,,0,1c9
02-22 14:25:13.609   337   760 I Gecko   : RIL Worker: [0] data registration state: 2,,,,0,20,,,,,
02-22 14:25:14.386   337   760 I Gecko   : RIL Worker: [0] data registration state: 2,,,,0,20,,,,,
02-22 14:25:14.389   337   760 I Gecko   : RIL Worker: [0] voice registration state: 1,2f46,0090d9c4,3,,,,0,,,,,,0,1c9
02-22 14:25:21.247   337   760 I Gecko   : RIL Worker: [0] voice registration state: 1,2f46,0090d9c4,3,,,,0,,,,,,0,1c9
02-22 14:25:21.275   337   760 I Gecko   : RIL Worker: [0] data registration state: 2,,,,0,20,,,,,
Scorpion kernel lacks FANOTIFY and SECCOMP
Flags: needinfo?(afarden)
Bluetooth was broken because |bluetooth.default| package was missing from PRODUCT_PACKAGES
Let's find why NFC regressed. When enabling it we get:
> 02-22 17:26:09.790: D/(5408): phNxpLog_InitializeLogLevel: global =1, Fwdnld =1, extns =1,                 hal =1, tml =1, ncir =1,                 ncix =1
> 02-22 17:26:09.790: E/NxpTml(5408): _i2c_open() Failed: retval ffffffff
> 02-22 17:26:09.790: E/NxpHal(5408): phTmlNfc_Init Failed
Per private discussion, NFC was broken because of missing symlink with /dev entries
(Assignee)

Comment 38

2 years ago
GSM slipped through me tests because it is a Rhine platform specific issue. We can't solve it; the issue lies in the blobzip. I confirmed GSM is not working on AOSP too. Sony has been informed.

(We could of course use an older blobzip)

Yukon and Shinano (and Kitakami if/when we are able to support this platform) all have working GSM on B2G.
(Assignee)

Comment 39

2 years ago
Created attachment 8722519 [details] [review]
Manifest PR
Attachment #8721802 - Attachment is obsolete: true
Flags: needinfo?(afarden)
Attachment #8722519 - Flags: review?(lissyx+mozillians)
Attachment #8722519 - Flags: review?(lissyx+mozillians) → review+
https://github.com/mozilla-b2g/timekeep/commit/460869402e019b122c4e5ffce19bfbbad026c0fe
https://github.com/mozilla-b2g/macaddrsetup/commit/1e31df0400fda7d80151bd4c5441027cd49749f8
https://github.com/mozilla-b2g/device-sony-common/commit/8956834338d21b18718149575a6c0a1466446cda
https://github.com/mozilla-b2g/codeaurora_kernel_msm/commit/36e3286b400566d0cfe9ea9f54ca76039910bf92
https://github.com/mozilla-b2g/device-sony-rhine/commit/f8fc588e9bb7c4dc89e4dd0625dcc363ad042edb
https://github.com/mozilla-b2g/device-sony-shinano/commit/0d4a0909139c3c50075daa4a2300744b3921301d
https://github.com/mozilla-b2g/device-sony-yukon/commit/ddbb9c51a1ef0415dd91901cf00e5f821f9165b4
https://github.com/mozilla-b2g/device-sony-scorpion_windy/commit/03bf71ec1b0a934e36507e10eb80bc5869f7c72b
https://github.com/mozilla-b2g/device-sony-leo/commit/7fa58489a5ac3977d7609271b67f12f7609b2e01
https://github.com/mozilla-b2g/device-sony-aries/commit/27a90ca4e11e7954fd395fc0b62316c863fcb323
https://github.com/mozilla-b2g/device-sony-scorpion/commit/7a511ecb29bd873156d7908ecc56d01e13512485
https://github.com/mozilla-b2g/device-sony-sirius/commit/763c7408f3132e7558d1f42a75ca212d59634259
https://github.com/mozilla-b2g/device-sony-seagull/commit/7e4049d36d071430741b0d7ccfc003b3a5c22272
https://github.com/mozilla-b2g/device-sony-eagle/commit/c32653915fc96c1fbf75bffb95ad9485fa005c6f
https://github.com/mozilla-b2g/device-sony-flamingo/commit/ad9110649ec467518900932f648e45ce36effaeb
https://github.com/mozilla-b2g/device-sony-honami/commit/e2496d1b4de848042726d23eb3164c2281c2d526
https://github.com/mozilla-b2g/device-sony-amami/commit/6fa4f527b07a997c650d2b2e586839bdd29f9820
https://github.com/mozilla-b2g/b2g-manifest/commit/7fafd8003c6157e23f1145f7c58c4af0ebf699aa
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Updated

2 years ago
Blocks: 1250588
NOTE: this commit breaks all b2g builds on build infra (bug 1250588). They will remain broken until the new repos are mirrored to git.mozilla.org

Please see https://wiki.mozilla.org/ReleaseEngineering/How_To/Request_a_New_Repository#Requester.27s_Actions: for details on what needs to be filed, and it should block this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Depends on: 1250864
(In reply to Hal Wine [:hwine] (use NI) from comment #42)
> NOTE: this commit breaks all b2g builds on build infra (bug 1250588). They
> will remain broken until the new repos are mirrored to git.mozilla.org
> 
> Please see
> https://wiki.mozilla.org/ReleaseEngineering/How_To/
> Request_a_New_Repository#Requester.27s_Actions: for details on what needs to
> be filed, and it should block this bug.

Thanks, sorry for the noise, done as bug 1250864
Flags: needinfo?(hwine)
Flags: needinfo?(hwine)
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.