Text input element becomes unresponsive to text input #2

RESOLVED WORKSFORME

Status

()

Core
Editor
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: marcino245, Unassigned)

Tracking

47 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160212030242

Steps to reproduce:

Bumping https://bugzilla.mozilla.org/show_bug.cgi?id=851133

I added several comments to 851133 but I'm not sure if my problem is a duplicate or not, althought the sympthoms are the same, the reasons may be different. Also I don't know if 851133 is still active or not as it is old and has: a needinfo flag and the author is gone for 3 years, the author has Mac + firefox 17, I have Windows XP + Firefox Nightly 47.0a1, and a code the author has posted doesn't reproduce on me.
.
Mozilla developers are free to decide if this is a duplicate or not.
(Reporter)

Updated

2 years ago
tracking-e10s: --- → ?
OS: Unspecified → Windows XP
Hardware: Unspecified → x86

Comment 1

2 years ago
Bug 851133 is not about e10s. If your issue is gone with e10s disabled, it's a different bug.

Updated

2 years ago
Component: Untriaged → Editor
Product: Firefox → Core

Updated

2 years ago
Flags: needinfo?(twalker)
marcino,

Please attach a full copy of your about:support, including the list of add-ons you have installed when encountering this bug.  Preferably, run with a completely fresh profile with no add-ons installed in that profile.

Thank you.
Flags: needinfo?(twalker) → needinfo?(marcino245)
(Reporter)

Comment 3

2 years ago
TracyWalker,

I think that you did not notice that I already mentioned that
> I made a fresh profile, but that did not help
and a fresh profile has no add-ons installed. 

But if you have noticed that and despite this you still for some other reasons need a full copy of about:support of my fresh profile, let me know.
Flags: needinfo?(marcino245)
yes, please provide full about:support
Flags: needinfo?(marcino245)
(Reporter)

Comment 5

2 years ago
> Application Basics
> ------------------
> 
> Name: Firefox
> Version: 47.0a1
> Build ID: 20160217062621
> Update Channel: nightly
> User Agent: Mozilla/5.0 (Windows NT 5.1; rv:47.0) Gecko/20100101 Firefox/47.0
> OS: Windows_NT 5.1 x86
> Multiprocess Windows: 1/1 (Enabled by user)
> Safe Mode: false
> 
> Crash Reports for the Last 3 Days
> ---------------------------------
> 
> Report ID: bp-da5b16cc-8199-48e1-95e8-7a1dd2160215
> Submitted: 2 days ago
> 
> All Crash Reports
> 
> Extensions
> ----------
> 
> Name: Firefox Hello Beta
> Version: 1.1.2
> Enabled: true
> ID: loop@mozilla.org
> 
> Name: Pocket
> Version: 47.0a1
> Enabled: true
> ID: firefox@getpocket.com
> 
> Name: Microsoft .NET Framework Assistant
> Version: 1.0
> Enabled: false
> ID: {20a82645-c095-46ed-80e3-08825760534b}
> 
> Graphics
> --------
> 
> Adapter Description: Intel(R) HD Graphics
> Adapter Drivers: igxprd32
> Adapter RAM: Unknown
> Asynchronous Pan/Zoom: wheel input enabled; touch input enabled
> Device ID: 0x0102
> Direct2D Enabled: Blocked for your graphics driver version.
> DirectWrite Enabled: false (0.0.0.0)
> Driver Date: 2-4-2013
> Driver Version: 6.14.10.5437
> GPU #2 Active: false
> GPU Accelerated Windows: 0/1 Basic (OMTC)
> Subsys ID: 77881462
> Supports Hardware H264 Decoding: No; Failed to create H264 decoder
> Vendor ID: 0x8086
> WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9 vs_3_0 ps_3_0)
> windowLayerManagerRemote: true
> AzureCanvasBackend: skia
> AzureContentBackend: cairo
> AzureFallbackCanvasBackend: cairo
> AzureSkiaAccelerated: 0
> 
> Important Modified Preferences
> ------------------------------
> 
> browser.cache.disk.capacity: 358400
> browser.cache.disk.filesystem_reported: 1
> browser.cache.disk.smart_size.first_run: false
> browser.cache.disk.smart_size.use_old_max: false
> browser.cache.frecency_experiment: 4
> browser.download.importedFromSqlite: true
> browser.places.smartBookmarksVersion: 7
> browser.sessionstore.upgradeBackup.latestBuildID: 20160217062621
> browser.startup.homepage_override.buildID: 20160217062621
> browser.startup.homepage_override.mstone: 47.0a1
> browser.tabs.remote.autostart: true
> browser.tabs.remote.autostart.2: false
> dom.apps.reset-permissions: true
> dom.mozApps.used: true
> extensions.lastAppVersion: 47.0a1
> gfx.blacklist.direct2d: 3
> media.gmp-gmpopenh264.abi: x86-msvc-x86
> media.gmp-gmpopenh264.lastUpdate: 1455620583
> media.gmp-gmpopenh264.version: 1.5.3
> media.gmp-manager.buildID: 20160217062621
> media.gmp-manager.lastCheck: 1455740785
> media.hardware-video-decoding.failed: true
> network.cookie.prefsMigrated: true
> network.predictor.cleaned-up: true
> places.history.expiration.transient_current_max_pages: 91303
> plugin.disable_full_page_plugin_for_types: application/pdf
> plugin.importedState: true
> services.sync.declinedEngines:
> 
> Important Locked Preferences
> ----------------------------
> 
> JavaScript
> ----------
> 
> Incremental GC: true
> 
> Accessibility
> -------------
> 
> Activated: false
> Prevent Accessibility: 0
> 
> Library Versions
> ----------------
> 
> NSPR
> Expected minimum version: 4.12 Beta
> Version in use: 4.12 Beta
> 
> NSS
> Expected minimum version: 3.23 Basic ECC Beta
> Version in use: 3.23 Basic ECC Beta
> 
> NSSSMIME
> Expected minimum version: 3.23 Basic ECC Beta
> Version in use: 3.23 Basic ECC Beta
> 
> NSSSSL
> Expected minimum version: 3.23 Basic ECC Beta
> Version in use: 3.23 Basic ECC Beta
> 
> NSSUTIL
> Expected minimum version: 3.23 Beta
> Version in use: 3.23 Beta
> 
> Experimental Features
> ---------------------
>
Flags: needinfo?(marcino245)
marcino, this comment you made in bug 851133 hints at some sort of performance hold up; "The text input freezes and also the char indicator dissapear and when I switch to another tab and back after several seconds, the problem dissapears."  Could you double check the freeze with your add-ons disabled vs enabled.  Is it better or worse with add-ons disabled.
Flags: needinfo?(marcino245)
(Reporter)

Comment 7

2 years ago
Hey, at the moment the bug seems to be "gone" even on my private profile (with many add-ons enabled) +  "multi-process" enabled (so I have it enabled), but as it is a random bug, I don't know what fixed it and I don't know if it is gone for sure. So I am just gonna wait a week, and if the bug won't come back, I will close it.

And what could trigger the bug to get fixed? Hell knows as several actions happened already like:

- I disabled broken UnMHT which was causing "switching between tabs url" problem (bug 1248120), so UnMHT could also cause Text input element becomes unresponsive to text input #2
- there were several Nighty updates, it is possible that any of them could fix the bug
Flags: needinfo?(marcino245)
Hmm, yes, it could be it's just not reliably reproducing.  Could be that something landed in a recent Nightly that fixed this issue.  If your curious about the later.  you can use mozregression to find the fix window. :)

I am going to remove tracking-e10s: ?. Please reset it, if you determine this is still occurring for you reliably without add-ons enabled.

Thanks for your efforts in reporting, tracking down and checking on your bugs.
(Reporter)

Updated

2 years ago
tracking-e10s: ? → ---
(Reporter)

Comment 9

2 years ago
OK. 

Thanks you too for your efforts in developing Firefox and fixing bugs.
(Reporter)

Comment 10

2 years ago
I realized just now, that the first reason (disabling UnMHT) is invalid (bogus) as an explanation for this bug, just a mistake, ignore it, as I have been experiencing the bug also on a fresh profile (no add-ons), therefore it had to be most likely the second reason:

> - there were several Nighty updates, it is possible that any of them could fix the bug

as disabling multi-process was causing the bug to dissapear but it also could be anything like something in Windows that has been disrupting Firefox and is gone now, or whatever else. It is hard to determine what was the cause as that was a random issue appearing on many random websites (those that I do not remember exactly) and is hard to reproduce. I rerun a single Nightly 13.02.2016 (a first time the bug has appear) with mozregression, and it was a little choppy as a whole but it is hard to make a conclusion if that was causing the input freeze or not, too random to reproduce. Some bugs or problems just appear at any time for unknown reasons, and then they dissapear at any time for unknown reasons.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.