Closed Bug 1248158 Opened 4 years ago Closed 4 years ago

Adding Mail View to the Mail Toolbar from Customize causes text to be cutoff when using Icons and Text

Categories

(Thunderbird :: Toolbars and Tabs, defect)

47 Branch
defect
Not set

Tracking

(thunderbird45 fixed, thunderbird46 fixed, thunderbird47 fixed)

RESOLVED FIXED
Thunderbird 47.0
Tracking Status
thunderbird45 --- fixed
thunderbird46 --- fixed
thunderbird47 --- fixed

People

(Reporter: walts48, Assigned: Paenglab)

References

Details

Attachments

(3 files, 1 obsolete file)

Attached image customized.png
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160211221018

Steps to reproduce:

Installed Daily 47.0a1 BuildID: 20160208030350
Start Daily with a new profile
Dismiss the account setup window
Select Customize from the Mail Toolbar
Add Mail Views to the Mail Toolbar
Select Icons and Text
Click Done


Actual results:

The text was cutoff at the bottom by the toolbar border.


Expected results:

The text below the icons should have been visible as it is with the Daily build from 02/07.
Probably caused by the size of the Mail View icon when added to the toolbar.
Attached patch dropmarker.patch (obsolete) — Splinter Review
This is a really weird issue. I tested always with the locationFolders menulist and there is no problem. But with the viewPicker menulist this happens. Both are menulists and I see no difference which leads to this.

I found the .menulist-dropmarker makes the problem, maybe that's why it was originally hidden. I'm using now a background image for the dropmarker. This needed now also some changes to .aw-menulist.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8719279 - Flags: review?(mkmelin+mozilla)
Comment on attachment 8719279 [details] [diff] [review]
dropmarker.patch

Review of attachment 8719279 [details] [diff] [review]:
-----------------------------------------------------------------

Looks ok to me, with some nits. r=mkmelin

::: mail/themes/linux/mail/compose/messengercompose.css
@@ +185,2 @@
>    -moz-appearance: none;
> +  padding-inline-end: 12px; 

trailing whitespace

@@ +368,5 @@
>  
> +.aw-menulist > .menulist-label-box {
> +  margin: -3px 1px;
> +  padding-inline-start: 12px; 
> +  padding-inline-end: 0; 

nit: these two lines have a trailing space

::: mail/themes/linux/mail/mailWindow1.css
@@ +403,2 @@
>    -moz-appearance: none;
> +  padding-inline-end: 12px; 

trailing whitespace
Attachment #8719279 - Flags: review?(mkmelin+mozilla) → review+
Attached patch dropmarker.patchSplinter Review
One time used a other editor and trailing white spaces are in. :(
Attachment #8719279 - Attachment is obsolete: true
Attachment #8720961 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/5b8a2f463f32
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 47.0
Blocks: 1244570
Comment on attachment 8720961 [details] [diff] [review]
dropmarker.patch

[Approval Request Comment]
Regression caused by (bug #): 1244570 which is in TB 45
User impact if declined: see screenshot in this patch
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low
Attachment #8720961 - Flags: approval-comm-beta?
Attachment #8720961 - Flags: approval-comm-aurora?
Comment on attachment 8720961 [details] [diff] [review]
dropmarker.patch

CSS = low risk ;-)
I think you can bring the system to a standstill with CSS. Sorry, my running joke.
Attachment #8720961 - Flags: approval-comm-aurora? → approval-comm-aurora+
Comment on attachment 8720961 [details] [diff] [review]
dropmarker.patch

http://hg.mozilla.org/releases/comm-esr45/rev/a9a9beabc137
Attachment #8720961 - Flags: approval-comm-beta? → approval-comm-beta+
Attachment #8720961 - Flags: approval-comm-beta+ → approval-comm-esr45+
You need to log in before you can comment on or make changes to this bug.