Please set unicode UTF-8 as default for sending Lithuanian e-mails

RESOLVED FIXED

Status

Mozilla Localizations
lt / Lithuanian
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: opensuse.lietuviu.kalba, Assigned: Rimas Kudelis)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 2016012300

Steps to reproduce:

Now Thunderbird use win1257 encoding as default for Lithuanian e-mails. 
Nowadays unicode is dominant everywhere and covers Lithuanian letters.

Please set unicode UTF-8 as default for sending Lithuanian e-mails

Comment 1

2 years ago
I don't understand the problem. The default configuration for TB is to send all new e-mail as UTF-8 always. You can set the default:
Tools > Options, Display tab, Formatting, Advanced. There is also a checkbox to use this default in replies.
(Reporter)

Comment 2

2 years ago
If UTF-8 is already default, then it is OK :) 
I just remember, that email was sent in another encoding using default config...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Comment 3

2 years ago
We're happy to see a bug closed, however, I don't understand your comment:
"that email was sent in another encoding using default config"
The default config *is* UTF-8. So how can it be sent in another encoding if you're using default config?

Personally, I don't use UTF-8. Being Western European, I use windows-1252. But anyone can decide for themselves ;-)
(Reporter)

Comment 4

2 years ago
Maybe your was true, about settings for answering

Comment 5

2 years ago
It's a localized pref
http://mxr.mozilla.org/l10n/source/lt/mail/chrome/messenger/messenger.properties#259
Assignee: nobody → rimas
Status: RESOLVED → UNCONFIRMED
Component: Preferences → lt / Lithuanian
Product: Thunderbird → Mozilla Localizations
QA Contact: rimas
Resolution: INVALID → ---

Comment 6

2 years ago
And I agree, every local that doesn't have any special needs (like japan) should use utf-8 by default. It worked out well for en-US, so the chance that it would work elsewhere is quite slim.
(Assignee)

Updated

2 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 7

2 years ago
Magnus, do you remember if mailnews.view_default_charset is a fallback after UTF-8 or not? I mean, will UTF-8 be detected automatically in received e-mails, or do I have to set mailnews.view_default_charset to UTF-8 as well for it to work (which I don't think I'm going to do)?
(Assignee)

Comment 8

2 years ago
By the way, the reason why I hadn't set UTF-8 as default until now is because IIRC it is an automatic fallback for cases when the alphabet used during composition doesn't fit into the default charset. But yeah, I suppose it's time to let these old 8-bit charsets go.

Comment 9

2 years ago
This bug is about mailnews.send_default_charset. 

mailnews.view_default_charset is only used as fallback in the rare case the mail do not declare a charset at all (usually buggy auto mail sent by software). What charset that really is is anybody's guess...
(Assignee)

Comment 10

2 years ago
Fixed for both Thunderbird and SeaMonkey:

http://hg.mozilla.org/releases/l10n/mozilla-aurora/lt/rev/06cbfdb2926f
http://hg.mozilla.org/releases/l10n/mozilla-aurora/lt/rev/cd5b84404f16

http://hg.mozilla.org/releases/l10n/mozilla-beta/lt/rev/0258f5f2298d
http://hg.mozilla.org/releases/l10n/mozilla-beta/lt/rev/1e62d42735b7

I hope I won't forget to sign off my update so that it gets into Thunderbird 45. If not, this will get to wait until the end of this year.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

2 years ago
Ačiū, Rimai, kad ištaisei!

Thanks, Rimai, for reopening and fixing!
You need to log in before you can comment on or make changes to this bug.