Clicking color circle near color in property value opens color tooltip far away from the circle if I was editing corresponding property name

VERIFIED DUPLICATE of bug 1248274

Status

P2
normal
VERIFIED DUPLICATE of bug 1248274
3 years ago
8 months ago

People

(Reporter: arni2033, Assigned: nchevobbe)

Tracking

Trunk

Firefox Tracking Flags

(firefox44 affected, firefox45 affected, firefox46 affected, firefox47 affected, firefox48 affected, firefox49 affected, firefox-esr38 unaffected, firefox50 verified)

Details

(Whiteboard: [btpp-fix-later], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8719308 [details]
2016.02.14 21-29-23.png

>>>   My Info:   Win7_64, Nightly 47, 32bit, ID 20160210071115
STR:
1. Open the following "data:" url or click URL in the form above
>   data:text/html,<style>body{filter: grayscale(100%) contrast(17%) drop-shadow(0px 2px 4px yellow);background:none repeat scroll 0% 0% transparent}
2. Open devtools -> Inspector, open "Rules" tab in sidebar, dock devtools to the bottom side of window
3.A) Click "filter"     string in sidebar.
     Then click yellow circle near string "yellow" in sidebar
3.B) Click "background" string in sidebar.
     Then click transparent circle in sidebar near string "transparent" in sidebar

AR:  Color tooltip opens at some fixed point on the top side of devtools toolbox
ER:  Color tooltip should open near the color circle

Note: I'm not sure if I should call it a regression but a few versions earlier,
      nothing happened after Step 3. And now this bug happens.
Reproduced in 43 - 46. So this has been here for some time. 
Maybe the first click outside an input field used to be ignored before, which is why nothing was happening after step 3 a few versions ago.

What I think might be happening here is that when the property name is blurred, the full declaration is refreshed, and that means its DOM is re-created. So by the time the colorpicker tooltip panel is ready to be shown, its anchor is gone, and so it defaults to some other position.

Investigation for this bug should start in devtools\client\inspector\rules\views\text-property-editor.js (probably in `_onNameDone`).
(Reporter)

Comment 2

3 years ago
This issue was implemented in bug 1136257 (hm, how kind of Mozilla to store such old builds)

94df0a4a500642a12d92b0db37565a56af5e57f7 - click on color circle (STR in comment 0) is ignored
844fd3a2a85e74c0a8c23b8cb857ae521ff709a8 - this bug (started in Firefox 40)
> pushlog:   https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=94df0a4a500642a12d92b0db37565a56af5e57f7&tochange=844fd3a2a85e74c0a8c23b8cb857ae521ff709a8

Note that clicking filter_circle was always ignored in this case (and IS ignored, to this day)
Blocks: 1136257
status-firefox44: --- → affected
status-firefox-esr38: --- → unaffected
(Reporter)

Updated

3 years ago
See Also: → bug 1248274
Filter on CLIMBING SHOES
Priority: -- → P2
Whiteboard: [btpp-fix-later]
Priority: P2 → P3
Priority: P3 → P2
Priority: P2 → P5
Priority: P5 → P2
(Assignee)

Updated

3 years ago
Assignee: nobody → chevobbe.nicolas
(Assignee)

Comment 4

3 years ago
Hi arni2033,

This should be fixed in Nightly (by Bug 1248274 patch).
Can you confirm ? 

Thanks
Flags: needinfo?(arni2033)
(Reporter)

Comment 5

3 years ago
Yes. Not only color circle was fixed, but also all other cases (filter, animation, degrees) of
this bug and bug 1248274 are now fixed. Tested on URL:
> data:text/html,<style>body{filter: grayscale(100%) contrast(17%) drop-shadow(0px 2px 4px yellow);background: linear-gradient(45deg, red,blue);animation: 1s all ease;}
Flags: needinfo?(arni2033)
(Assignee)

Comment 6

3 years ago
Fixed in Bug 1248274
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1248274
(Reporter)

Comment 7

3 years ago
Affected:   Win7_64, Nightly 49, 32bit, ID 20160526082509  (2016-05-26)
Fixed on:   Win7_64, Nightly 50, 32bit, ID 20160606131341  (2016-06-06)
Status: RESOLVED → VERIFIED
status-firefox48: --- → affected
status-firefox49: --- → affected
status-firefox50: --- → verified

Updated

8 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.