Nice to have the default string "search or enter address" in search bar

RESOLVED FIXED

Status

Firefox OS
Gaia::TV
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: cindylee, Assigned: danhuang)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.6 fixed, b2g-master fixed)

Details

(Whiteboard: [ft:conndevices])

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8719357 [details]
NG.png

[Description]
The default string "search or enter address" is NOT shown in search bar.

[Test Steps]
1. Launch Browser.
2. Observe the search bar.
3. The default string "search or enter address" is NOT shown in search bar.
4. Open a private window.
5. Observe the search bar.
6. The default string "search or enter address" is NOT shown in search bar.

[Expected Result]
3. The default string "search or enter address" is shown in search bar.
6. The default string "search or enter address" is shown in search bar.

[Actual Result]
3. The default string "search or enter address" is NOT shown in search bar.
6. The default string "search or enter address" is NOT shown in search bar.

[Frequency]
5/5

[Build Info]
Environment: 2.6 Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/65936e9bcc5e6f6636b5cee9af98c1789ac09970
gecko:
https://hg.mozilla.org/mozilla-central/rev/e355cacefc881ba360d412853b57e8e060e966f4

[TCID]
16647
(Reporter)

Comment 1

2 years ago
Created attachment 8719358 [details]
Private_Browsing_1.png

Comment 2

2 years ago
Hi Cynthia, please help to confirm if this is regression or the case needs to be revised, thanks.
Flags: needinfo?(ctang)

Updated

2 years ago
Assignee: nobody → yliao
Hi Mike,
The string is nice to have, not must to have. Private_Browsing_1 is captured from the Visual spec. 
 
Hi Cindy,
The red frame 1 is Toolbar Panel Group. Please focus on the style, not the string. Thank you.

By the way, TCID 16647 is for "Private Browsing-Visit sites without making history".
Flags: needinfo?(ctang)
QA Whiteboard: [COM=TV Browser]
status-b2g-v2.5: affected → ---
Summary: The default string "search or enter address" is NOT shown in search bar. → Nice to have the default string "search or enter address" in search bar

Updated

2 years ago
blocking-b2g: --- → 2.6?

Updated

2 years ago
blocking-b2g: 2.6? → 2.6+

Comment 4

2 years ago
Hi Yifan,
Do you still working on this?
Flags: needinfo?(yliao)
No, thanks for the reminder.
Flags: needinfo?(yliao)

Updated

2 years ago
Assignee: yliao → nobody

Comment 6

2 years ago
Dan, could you help here? thanks.
Assignee: nobody → dhuang
Created attachment 8752444 [details] [review]
[gaia] danhuang1202:1248310_add_placeholder_to_url_input > mozilla-b2g:master
(Assignee)

Comment 8

2 years ago
Comment on attachment 8752444 [details] [review]
[gaia] danhuang1202:1248310_add_placeholder_to_url_input > mozilla-b2g:master

Please help review this patch. This patch add placehoder: 'Search or enter address' in the url input element.
Attachment #8752444 - Flags: review?(yliao)
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED

Updated

2 years ago
Attachment #8752444 - Flags: review?(yliao) → review+
(Assignee)

Comment 9

2 years ago
Thanks for the review.
Merge in master: https://github.com/mozilla-b2g/gaia/commit/d74ae4b10f2228a071a7d7a224b26877ad49848e
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

2 years ago
Comment on attachment 8752444 [details] [review]
[gaia] danhuang1202:1248310_add_placeholder_to_url_input > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): TV 2.6
[User impact] if declined: Not align to visual spec
[Testing completed]: Yes
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8752444 - Flags: approval-gaia-v2.6?(jocheng)

Updated

2 years ago
status-b2g-v2.6: --- → affected
status-b2g-master: affected → fixed

Comment 11

2 years ago
Comment on attachment 8752444 [details] [review]
[gaia] danhuang1202:1248310_add_placeholder_to_url_input > mozilla-b2g:master

Approve for TV 2.6
Attachment #8752444 - Flags: approval-gaia-v2.6?(jocheng) → approval-gaia-v2.6+
Created attachment 8754241 [details] [review]
[gaia] danhuang1202:2.6_1248310_add_placeholder_to_url_input > mozilla-b2g:v2.6
(Assignee)

Comment 13

2 years ago
Merge in v2.6: https://github.com/mozilla-b2g/gaia/commit/fcc70a2e4fd475c1b4a9dfd9be82042621e0d70a
status-b2g-v2.6: affected → fixed
You need to log in before you can comment on or make changes to this bug.