Closed Bug 1248377 Opened 4 years ago Closed 4 years ago

Conversation window isn't resizing when text chat is activated/displayed

Categories

(Hello (Loop) :: Client, defect, P1, blocker)

defect
Points:
2

Tracking

(firefox46+ fixed, firefox47+ verified)

VERIFIED FIXED
mozilla47
Iteration:
47.2 - Feb 22
Tracking Status
firefox46 + fixed
firefox47 + verified

People

(Reporter: standard8, Assigned: mikedeboer)

References

Details

(Keywords: regression)

Attachments

(2 files)

When I join a room, the text chat window has stopped resizing. This breaks the layout of the chat window.

It should resize when text chat is enabled (just the text input line), or when there's text messages to be displayed.
Rank: 1
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Iteration: --- → 47.2 - Feb 22
Points: --- → 2
Flags: qe-verify+
Flags: firefox-backlog+
Comment on attachment 8719491 [details] [diff] [review]
Patch v1: adding global event listeners is wrong in hindsight

Review of attachment 8719491 [details] [diff] [review]:
-----------------------------------------------------------------

That's better, seems to be working right now.
Attachment #8719491 - Flags: review?(standard8) → review+
https://hg.mozilla.org/integration/fx-team/rev/5d8b06b5b67e5422e6168fcfaa2ed4fac58b2640
Bug 1248377: adding global event listeners is wrong in hindsight - events stopped arriving in handlEvent. r=Standard8
Duplicate of this bug: 1248527
Duplicate of this bug: 1248528
https://hg.mozilla.org/mozilla-central/rev/5d8b06b5b67e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
QA Contact: bogdan.maris
Verified that Conversation window resizes properly when someone joins the room (chat area is displayed). 
We used latest Nightly 47.0a1 and latest version of Hello add-on (at this time) 1.1.9 across platforms (Windows 10 64-bit, Windows 7 64-bit, Mac OS X 10.11.1 and Ubuntu 14.04 32-bit).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Attached patch Patch for auroraSplinter Review
Approval Request Comment
[Feature/regressing bug #]: bug 1245813
[User impact if declined]: The Hello window doesn't resize correctly and makes the layout look weird.
[Describe test coverage new/current, TreeHerder]: Landed in m-c for a few weeks.
[Risks and why]: Low, minor correction for listeners
[String/UUID change made/needed]: None
Attachment #8726665 - Flags: approval-mozilla-aurora?
Regression from 46, tracking and marking affected
Comment on attachment 8726665 [details] [diff] [review]
Patch for aurora

Fix for layout regression from 46, verified in m-c, let's uplift it.
Attachment #8726665 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.