[CRASH] A crash occurs with a A element that contains both HREF and ONFOCUS attributes.

CLOSED DUPLICATE of bug 12485

Status

()

P3
major
CLOSED DUPLICATE of bug 12485
19 years ago
2 years ago

People

(Reporter: chrispetersen, Assigned: vidur)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Version: Apprunner
Build: 1999082412 (Aug 24 M9)
Platform: All
Expected Results: The HREF source should load in the browser window.
What I got: A crash occurs after clicking on the OK button in a JS dialog.
Steps to reproduce:


1) Open the following file:http://slip/projects/marvin/html/a_onfocus.html
2) Click on the link to activate the onfocus handler.
3) In the JS dialog, click OK.
4) The application should crash.
(Reporter)

Comment 1

19 years ago
Here is a stack crawl:


Call Stack:    (Signature = nsEventStateManager::SendFocusBlur debcffa9)

   nsEventStateManager::SendFocusBlur
                                              [d:\builds\seamonkey\mozilla\
layout\events\src\nsEventStateManager.cpp, line 1260]

   nsEventStateManager::SetContentState
                                              [d:\builds\seamonkey\mozilla\
layout\events\src\nsEventStateManager.cpp, line 1129]

   nsHTMLAnchorElement::HandleDOMEvent
                                              [d:\builds\seamonkey\mozilla\
layout\html\content\src\nsHTMLAnchorElement.cpp, line 301]

   nsGenericDOMDataNode::HandleDOMEvent
                                              [d:\builds\seamonkey\mozilla\
layout\base\src\nsGenericDOMDataNode.cpp, line 720]

   nsXMLCDATASection::HandleDOMEvent
                                              [d:\builds\seamonkey\mozilla\
layout\xml\content\src\nsXMLCDATASection.cpp, line 195]

   PresShell::HandleEvent
                                              [d:\builds\seamonkey\mozilla\
layout\html\base\src\nsPresShell.cpp, line 1869]

   nsView::HandleEvent
                                              [d:\builds\seamonkey\mozilla\view\
src\nsView.cpp, line 835]

   nsView::HandleEvent
                                              [d:\builds\seamonkey\mozilla\view\
src\nsView.cpp, line 820]

   nsView::HandleEvent
                                              [d:\builds\seamonkey\mozilla\view\
src\nsView.cpp, line 820]

   nsView::HandleEvent
                                              [d:\builds\seamonkey\mozilla\view\
src\nsView.cpp, line 820]

   nsViewManager::DispatchEvent
                                              [d:\builds\seamonkey\mozilla\view\
src\nsViewManager.cpp, line 1611]

   HandleEvent
                                              [d:\builds\seamonkey\mozilla\view\
src\nsView.cpp, line 67]

   nsWindow::DispatchEvent
                                              [d:\builds\seamonkey\mozilla\
widget\src\windows\nsWindow.cpp, line 502]

   nsWindow::DispatchWindowEvent
                                              [d:\builds\seamonkey\mozilla\
widget\src\windows\nsWindow.cpp, line 523]

   nsWindow::DispatchMouseEvent
                                              [d:\builds\seamonkey\mozilla\
widget\src\windows\nsWindow.cpp, line 3273]

   ChildWindow::DispatchMouseEvent
                                              [d:\builds\seamonkey\mozilla\
widget\src\windows\nsWindow.cpp, line 3466]

   nsWindow::ProcessMessage
                                              [d:\builds\seamonkey\mozilla\
widget\src\windows\nsWindow.cpp, line 2529]

   nsWindow::WindowProc
                                              [d:\builds\seamonkey\mozilla\
widget\src\windows\nsWindow.cpp, line 572]

   KERNEL32.DLL + 0x3663 (0xbff73663)


   KERNEL32.DLL + 0x22894 (0xbff92894)


   0x00638c00

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
*** This bug has been marked as a duplicate of 12485 ***

Updated

19 years ago
Status: RESOLVED → CLOSED

Comment 3

19 years ago
Closed.
You need to log in before you can comment on or make changes to this bug.