Closed Bug 1248427 Opened 7 years ago Closed 7 years ago

Notifications aren't shown in the right of the screen

Categories

(Toolkit :: Notifications and Alerts, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox46 --- unaffected
firefox47 + fixed

People

(Reporter: marco, Unassigned)

References

()

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

If I run the demo on MDN, the first notification is shown in the center of the screen, the following ones move to the left until they reach the left side. Then, all the following ones are shown on the left side.
Ugh. :(  Which platform, and what's your display configuration like?
Linux (Ubuntu), the window manager is the default one (Compiz).

In the settings, I've set scaling to 1,62.

`xrdb -query | grep dpi` tells me `Xft.dpi 156`
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Version: unspecified → Trunk
What values of devicePixelRatio do we get for a window on each of your displays?

(One easy way to find out: load https://people.mozilla.org/~jkew/tests/devPixRatio.html, and drag the window to each display in turn.)
I'm using a single display (I can reproduce the bug no matter how many displays I use).

Device Pixel Ratio: 2
Tracking for 47 since this sounds like a recent regression. Does it also affect aurora 46?
Flags: needinfo?(mcastelluccio)
I believe this is caused by bug 890156, which was backed out of Aurora. I'll test and update the flags.
Flags: needinfo?(mcastelluccio)
Huh, this is interesting.... for me (on Ubuntu 15.10) the notifications seem to be placed correctly if the display scaling is *below* 1.5 (tested at 1.25 and 1.38 as well as 1.0, and they worked OK in all cases). But at 1.5 or higher, they get misplaced.
Whiteboard: [gfx-noted]
I believe the patch that just landed in bug 1240749 will fix this. We should re-test once that hits Nightly.
Fixed!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.