YouTube Video flickers - FF44+ (mp4 with Hardware Acceleration)

RESOLVED DUPLICATE of bug 1260611

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1260611
2 years ago
2 years ago

People

(Reporter: bhanek, Unassigned)

Tracking

44 Branch
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(firefox46 affected, firefox49 fixed)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Steps to reproduce:

FF44 or 45 beta running on Win8.1 64bit.
I have dual monitor setup and it happens mainly if I play 2 or more video at the same time or have game running on one screen and video on the other.
It only seems to happen on youtube with mp4 playback - if I enable MSE VP9 video plays ok. Turning Hardware Acceleration off also fixes it. (new profile and disabling all addons doesn't, also tried few different video drivers with no luck)


Actual results:

It happens randomly on average once every 20 seconds but with very big variance and it looks like 2-3 frames are out of order.



Expected results:

Never had this problem before and on FF 43 everything is ok.
----
I have Nvidia GTX760 and I tried monitoring some parameters with Afterburner like VID decoding, GPU usage, frequency etc. and nothing looks abnormal. (I also have GPU in my i5 enabled since I use it for QuickSync video encoding when screen capturing. However it doesn't seem do be decoding anything if reading in MSI Afterburner are correct).
If necessary I can try to record short video of this happening and upload somewhere.
(Reporter)

Updated

2 years ago
Component: Untriaged → General
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: General → Audio/Video: Playback
Product: Firefox → Core

Comment 1

2 years ago
I have very similar experience.  New windows install, video drivers updated.


Windows 10 (64bit)
Radeon 6850
64 bit FF client.

Seems to be okay up to FF43,  44 and 45 I get the same stuttering video.  Sound is fine, but video glitches in much the same manner.
Is this issue reproducible in nightly?
(Reporter)

Comment 3

2 years ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #2)
> Is this issue reproducible in nightly?

yes, just tested on 48.0a1 (2016-04-12) - still there
(Reporter)

Comment 4

2 years ago
forgot to add - the bug was also present in FF43, I didn't noticed on youtube but I got the same "frames jumping" effect on twitch with html5 player
I think this is the same issue as bug 1260611.
See Also: → bug 1260611
Is the issue still reproducible in nightly?

Comment 7

2 years ago
Yes.    As a side note maybe for clarity and tracking, it seems to only happen when I have a game "full window" on one monitor, and I have the browser open on the other monitor.  When I try to play a video I get the jittery stuttering playback.  Easily seen on YouTube.com and it's not a Flash problem as I am using the HTML5 version of the website.
(Reporter)

Comment 8

2 years ago
After a day of testing it seems it's fixed in nightly 49.0a1 (2016-05-20).
(In reply to Mike J from comment #7)
> Yes.    As a side note maybe for clarity and tracking, it seems to only
> happen when I have a game "full window" on one monitor, and I have the
> browser open on the other monitor.  When I try to play a video I get the
> jittery stuttering playback.  Easily seen on YouTube.com and it's not a
> Flash problem as I am using the HTML5 version of the website.

You're saying you can reproduce it in nightly 49? If so, can you paste in the graphics section of about:support?

Comment 10

2 years ago
Actually, I wasn't updated, now I am, sorry about the confusion.

As far as I can tell using the latest nightlies it is fixed too.  I believe whatever fix went into bug 1260611 was apparently the same bug as this.

I hope and request that maybe that fix could push forward from its slated landing on FF49 to the next major revision (47?) as it is a huge deal-breaker when it comes to using sites like Youtube, etc.

That said, it may be a small percentage of people that experience it, I'm not sure.  It manifest itself for me, as I described above, when I had a game in full windowed mode on my primary monitor and Firefox open on the second monitor playing Youtube videos, but it sure was obvious.
(In reply to Mike J from comment #10)
> I hope and request that maybe that fix could push forward from its slated
> landing on FF49 to the next major revision (47?) as it is a huge
> deal-breaker when it comes to using sites like Youtube, etc.

Bug 1260611 made it to 47 so hopefully that fixes the issue.
status-firefox46: --- → affected
status-firefox49: --- → fixed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1260611
You need to log in before you can comment on or make changes to this bug.