Closed Bug 1248455 Opened 4 years ago Closed 4 years ago

Google Chrome has better diagnostics when manifest.json is invalid

Categories

(WebExtensions :: Untriaged, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1224591

People

(Reporter: wbamberg, Unassigned)

Details

Attachments

(1 file)

Attached image json-error.png
I tried an add-on that had an extra trailing comma in the manifest, like this:

  "permissions": [
      "tabs",
  ]

Trying to install in Firefox, I get a dialog saying:

"This add-on could not be installed because it appears to be corrupt"

Trying to install in Chrome, I a dialog showing me exactly where the error was, and letting me retry after fixing it. See the attached screenshot.
I think, if we want people to write WebExtensions, showing errors like this will be _very_ important…
Flags: blocking-webextensions?(amckay)
We actually do show these kinds of errors in the Browser Console, they're just not very easy to find. I think there are at least a couple of bugs about this already.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1224591
Flags: blocking-webextensions?(amckay) → blocking-webextensions+
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.