Fix browser_contextSearchTabPosition.js for e10s

RESOLVED DUPLICATE of bug 1094761

Status

()

Firefox
Search
RESOLVED DUPLICATE of bug 1094761
2 years ago
2 years ago

People

(Reporter: Felipe, Assigned: Felipe)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(e10s+, firefox47 affected)

Details

(Assignee)

Description

2 years ago
This test hits the network (because it opens a tab with a search query to the default search engine), and this generates an intentional crash because tests shouldn't be hitting the network. The theory that this doesn't happen in non-e10s is that the tab closing happens fast enough to cancel the network request, but that doesn't hold for e10s.

The right fix is to make it use a test-engine that points to a mochi.test url. I moved it to browser/components/search to easily use a helper function.

It appears this test was disabled on mac for being intermittent.. I ran it several times here and didn't see it happening, but I kept the skip-if == mac just in case to not have this bug backed out.
(Assignee)

Comment 1

2 years ago
(ahh, wasted a nice bug number)
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1094761
You need to log in before you can comment on or make changes to this bug.