Link clicker pointer offset down when seen on the desktop client side

RESOLVED FIXED

Status

Hello (Loop)
Client
P1
normal
Rank:
5
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: RT, Assigned: fcampo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
STR:
1 Generator creates and shares room
2 Clicker joins
3 Generator can see clicker pointer but it is represented lower than what is the true position on the clicker side
Can you take a screenshot? I wonder if it's for a particular aspect ratio or zoom. Is it incorrectly offset by some fixed amount -- perhaps the height of the notification bar?
Fernando, please can you take a look at this with RT today?
Rank: 5
Flags: needinfo?(fernando.campo)
Priority: -- → P1
(Reporter)

Comment 3

3 years ago
Created attachment 8719746 [details]
Capture d’écran 2016-02-16 à 13.14.24.png
(Reporter)

Comment 4

3 years ago
Comment on attachment 8719746 [details]
Capture d’écran 2016-02-16 à 13.14.24.png

Pointer not captured on the screenshot
Attachment #8719746 - Attachment is obsolete: true
(Reporter)

Comment 5

3 years ago
See the following video of the issue: http://g.recordit.co/FnN38KSZka.gif (the blue circle on the left if the link clicker pointer, the blue pointer on the right is how it gets represented.
There is a very noticeable vertical offset but also a small horizontal offset.
(In reply to Romain Testard [:RT] from comment #5)
> http://g.recordit.co/FnN38KSZka.gif
The pointer seems to be incorrectly offset by 45px, which visually seems to match the height of the top bar ("Firefox Hello" video/audio mute) in the new layout from bug 1238530.

mancas, any suggestions for fcampo on what might have changed this? I'm pretty sure the standalone -> desktop shared pointer was much closer when the patch was initially implemented, but a lot of things landed at the same time.
Flags: needinfo?(b.mcb)
Perhaps could be caused by the padding added in the new link clicker UI?
Flags: needinfo?(b.mcb)
Created attachment 8719858 [details] [review]
[loop] fcampo:pointer-offset-1248530 > mozilla:master
(Assignee)

Comment 9

3 years ago
Comment on attachment 8719858 [details] [review]
[loop] fcampo:pointer-offset-1248530 > mozilla:master

Indeed the infobar offset is the culprit.

I just added an offset calculation when the mousemove event is registered, I think it's better for the future than just subtract 40px.
Flags: needinfo?(fernando.campo)
Attachment #8719858 - Flags: review?(edilee)
Attachment #8719858 - Flags: review?(b.mcb)
(Assignee)

Updated

3 years ago
Assignee: nobody → fernando.campo
Comment on attachment 8719858 [details] [review]
[loop] fcampo:pointer-offset-1248530 > mozilla:master

r=Mardak using getBoundingClientRect instead of implementing a custom _getOffset.
Attachment #8719858 - Flags: review?(edilee)
Attachment #8719858 - Flags: review?(b.mcb)
Attachment #8719858 - Flags: review+
(Reporter)

Updated

3 years ago
Summary: Link clicker pointer not offset down when seen on the desktop client side → Link clicker pointer offset down when seen on the desktop client side
(Assignee)

Comment 11

3 years ago
merged - fa9b8b1ab0b7d3f27a80d939a2c45522187547ed
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.