[DeviceOrientationEvent] Firefox 44: wrong value of alpha, beta, gamma angles.

RESOLVED DUPLICATE of bug 1205649

Status

()

Core
DOM: Device Interfaces
RESOLVED DUPLICATE of bug 1205649
2 years ago
8 months ago

People

(Reporter: Kirill Osipov, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Steps to reproduce:

User Agent: Mozilla/5.0 (Linux; Android 5.0.1; SM-N910C Build/LRX22C) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.34 Mobile Safari/537.36

Steps:
1) disable screen rotation,
2) open Firefox 44,
3) open http://www.audero.it/demo/device-orientation-api-demo.html 
or 
https://developer.mozilla.org/en-US/docs/Web/API/Detecting_device_orientation#Orientation_example
4) place device in landscape orientation,
5) rotate device around local Y-axis(see http://w3c.github.io/deviceorientation/spec-source-orientation.html#deviceorientation).


Actual results:

Gamma goes to 90 degrees, beta has some value (name it beta'), alpha has alpha' value (name it alpha'). If gamma is close to 90 degrees, beta changes to (180 - beta') and alpha does not change value.


Expected results:

Gamma goes to 90 degrees, beta is beta', alpha is alpha'. If gamma is close to 90 degrees, gamma changes to -90 degrees, beta changes to (180 - beta'), alpha changes to (alpha' + 180) mod 360.

Updated

2 years ago
Component: Untriaged → DOM: Device Interfaces
Product: Firefox → Core
William, what do you think here?
Flags: needinfo?(wchen)
Whiteboard: dom-triaged btpp-followup-2016-02-29
Whiteboard: dom-triaged btpp-followup-2016-02-29 → btpp-followup-2016-03-07

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(wchen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1205649
Whiteboard: btpp-followup-2016-03-07
(Reporter)

Comment 3

8 months ago
It seems the bug is still there.

User Agent: Mozilla/5.0 (Android 6.0.1; Mobile; rv:52) Gecko/52.0 Firefox/52.0

As you can see on photos mobile has different orientations but angles are same

https://www.blend4web.com/media/uploads/0aec8a8e-ad79-4f24-a8b3-df37a42bbf90/IMG_20161201_002407.jpg

https://www.blend4web.com/media/uploads/d63ee37a-f02b-4ff9-82e9-1f7c7f63c8dc/IMG_20161201_002249.jpg
You need to log in before you can comment on or make changes to this bug.