xml-rpc add extra linespace

VERIFIED FIXED

Status

()

Core
XML
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Mike Lee, Assigned: Samuel Sieb)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020130
BuildID:    2002013003

The xml-rpc currently adds "\r\n" before the post. Pending to bug 37773 but I
believe its not neccesary anymore, I could be wrong. But adding that extra line
actually break some rpc-rpc server.

http://lxr.mozilla.org/seamonkey/source/extensions/xml-rpc/src/nsXmlRpcClient.js#151

I would of produce a patch, but I still havent got around to install the patch
maker. So someone need to do it.
(Assignee)

Comment 1

17 years ago
Sorry, I really need to get my patch in.  I have it all fixed in my tree.  So
this bug is dependant on the xml-rpc authentication bug.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Windows NT → All
Hardware: PC → All
(Assignee)

Updated

17 years ago
Depends on: 122495
(Assignee)

Updated

17 years ago
No longer depends on: 122495
(Assignee)

Comment 2

17 years ago
checked in the patch from bug 122495 which fixed this problem
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 3

17 years ago
*** Bug 125886 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
Verified with 2002-02-16-06 linux build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.