Newsletter cgi/.pl subscribe form executes search code

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
P3
normal
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Steven Neil Groginsky, Assigned: Alexandru Savulov)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Newsletter cgi/.pl subscribe form executes search code inappropriately.  Should
not search at all.

Build 2002020703  Win98SE

I tried it in ie 5.01 and it worked fine.

url is http://www.freewareweb.com/newsindex.html

Relevant code (I think) follows:
<form ACTION="http://www.freewareweb.com/cgi-bin/subscribe.pl"
METHOD=POST><p>&nbsp;<font SIZE=2>Your e-mail address:</font><br> &nbsp;<input
TYPE="TEXT" NAME="email" SIZE=20 MAXLENGTH=65><input
TYPE="HIDDEN" NAME="subscribe" VALUE="subscribe" ALIGN="TOP"><b><font
FACE="Arial"><br> &nbsp;<input TYPE=SUBMIT
VALUE="Subscribe"></form></td></table><p>Or, to <b>unsubscribe</b> from
FreewareWeb Online!, just enter your e-mail address below and <b><font
COLOR="#CC0033">CLICK</font></b> <b>Unsubscribe</b>. For a <b>change of e-mail
address</b>, subscribe with your new address and unsubscribe with your old
address.<p><table BORDER=0 WIDTH=200 BGCOLOR=#FFFFEE> <td> <form
ACTION="http://www.freewareweb.com/cgi-bin/subscribe.pl"
METHOD=POST><p>&nbsp;<font SIZE=2>Your e-mail address:</font><br> &nbsp; <input
Name="email" SIZE=20 MAXLENGTH=65><b><font FACE="Arial"><br> &nbsp;<input
TYPE="HIDDEN" NAME="subscribe" VALUE="unsubscribe" ALIGN="TOP"><br><input
TYPE=SUBMIT VALUE="Unsubscribe"> </form> </td></table><br><!--HERE-->

Comment 1

16 years ago
Reporter: It's impossible to debug this unless you provide a more complete
HTML snippet, including the "search code" which you say is executed.

Please create an "attchement" with this code, or provide an URL.

Thank you for using Bugzilla.

Comment 2

16 years ago
Reporter: I see that a URL is included in the description. Please enter it in
the URL field above (I lack the authority). But I'd still say that provided
information is probably insufficient, there must be server side issues involved.
Do you possibly have access to the web server's log file?

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago
happens w/ build: 2002021803  OS: WinXP

Comment 5

16 years ago
-->
Assignee: rods → alexsavulov

Updated

16 years ago
QA Contact: madhur → tpreston
(Assignee)

Comment 6

16 years ago
this is a dep (missing </form> end tag = DemoteForm issue) 
Depends on: 90756
Priority: -- → P3
Target Milestone: --- → Future

Comment 7

16 years ago
WFM Linux 2002042707 if I understand the steps.  Please post your steps to
reproduce.

Here's what I did.

1. Go to http://www.freewareweb.com/newsindex.html
2. Click "Subscribe" button near bottom of page (above "Unsubscribe")

EXPECTED RESULTS:
Goes to URL http://www.freewareweb.com/cgi-bin/subscribe.pl

ACTUAL RESULTS:
Works for me.
(Reporter)

Comment 8

16 years ago
Build ID: 2002042510 on win98se

WORKSFORME too.

Comment 9

16 years ago
Thanks, closing.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.