Closed Bug 1248791 Opened 4 years ago Closed 3 years ago

Need OTA build with Dogfood = 0 to disable data collection

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: jgong, Unassigned)

Details

Attachments

(1 file, 2 obsolete files)

As part of Smartphone sunsetting effort, we need to create a build for foxfooders (both community and Internal) with dogfood flag=0 to disable data collection.
Naoki, Please add your build links on this bug for reference.
Flags: needinfo?(nhirata.bugzilla)
Attached patch 0001-Remove-dogfood-patch.patch (obsolete) — Splinter Review
Patch to remove Dogfood=1 from dogfood builds.

Two builds were kicked off on the side : 
I kicked off a build of "dogfood" channel with Dogfood=0;
https://tools.taskcluster.net/task-inspector/#AsBJ3BThSHaEECFpD1j0bA/

And a nightly channel with the same build :
https://tools.taskcluster.net/task-inspector/#M-QjJQfhSrSu48mZx6zIFQ/

The build is based on QAnalyst report stating that : friday's build ( d05085d0b5acdcf6b7f646a45c9a7058a4085ff8 ) seemed the best for dogfood currently.
Flags: needinfo?(nhirata.bugzilla)
Hey Kevin, two builds to test in comment 2 in this week if you could please.
Flags: needinfo?(ktucker)
nightly version didn't seem to build right, I need the dogfood version to be checked.


I reran the spark nightly version for myself:
https://tools.taskcluster.net/task-inspector/#MsKUpCuDS2O5NjBXSoD2YQ/
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #4)
> nightly version didn't seem to build right, I need the dogfood version to be
> checked.
> 
> 
> I reran the spark nightly version for myself:
> https://tools.taskcluster.net/task-inspector/#MsKUpCuDS2O5NjBXSoD2YQ/

How is it looking?  Please don't push this OTA out yet. We want to time it with the outbound communication happening by end of next week to Community the Foxfooding program.
It didn't turn off dogfooding, I need to figure out why.
Attached patch 0001-remove-dogfood-1.patch (obsolete) — Splinter Review
For some reason, my change didn't take on the taskcluster build, I decided to have a different patch of just removing the dogfood line instead.
Attachment #8720016 - Attachment is obsolete: true
Turns out that it was specifically written in the mozharness script so it was redundant.
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #8)
> Created attachment 8721498 [details] [diff] [review]
> 0001-remove-dogfood-1.patch
> 
> Turns out that it was specifically written in the mozharness script so it
> was redundant.

Do you have an update on the updated patch?  We are hoping to push this OTA update next Wed, Feb 24.
We just need to test the builds:
** https://tools.taskcluster.net/task-inspector/#OG9D1UJaRtCslft1cNUx5g/
** https://tools.taskcluster.net/task-inspector/#JOMf3GtIS6qvpIwY-blRrA/

One is a dogfood channel build the other is a nightly build based off the same hash.
We're only testing the dogfood, I was going to play around with the nightly to see if I can just fota and change the channel to the nightly so we can get rid of the dogfood channel worry.
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #10)
> We just need to test the builds:
> ** https://tools.taskcluster.net/task-inspector/#OG9D1UJaRtCslft1cNUx5g/
> ** https://tools.taskcluster.net/task-inspector/#JOMf3GtIS6qvpIwY-blRrA/
> 
> One is a dogfood channel build the other is a nightly build based off the
> same hash.
> We're only testing the dogfood, I was going to play around with the nightly
> to see if I can just fota and change the channel to the nightly so we can
> get rid of the dogfood channel worry.

Thanks!  Just to confirm...this build is for Community participants.  If you are having some challenges, please let me know and we can get Jan to help us.
Naoki, can you confirm what date you took the latest build for this patch?
Flags: needinfo?(nhirata.bugzilla)
The buildid is purposely made : 20160212150237  It's the last known good build we have to date.
The build is based off the HG pull : 576a6dcde5b6
http://hg.mozilla.org/mozilla-central/rev/576a6dcde5b6


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
The results for the test for a OTA : 
* 68/69 passing
* 0 reboots
* 0 crashes

=================================

Smoke Test Failures:

New:

- https://bugzil.la/1250353 [Aries] Unable to send Files via bluetooth
  * Fails [6071]

Existing:

- None reported

=================================

Severe Issues:

- https://bugzil.la/1247665 Unable to save an image from a webpage
- https://bugzil.la/1245670 [Aries] crash in pthread_mutex_lock_impl | pthread_rwlock_timedrdlock
- https://bugzil.la/1245633 Locking the phone while going into card view causes the SHB and the lockscreen to not appear
- https://bugzil.la/1243880 Opening multiple apps in a quick manner causes scroll and home button to break
- https://bugzil.la/1243159 [Aries] Start Tour button sometimes does not function to progress through tutorials after FTU
- https://bugzil.la/1234694 Sound settings reset to default after OTA update
- https://bugzil.la/1232857 Time remaining for battery is incorrect at times
- https://bugzil.la/1205809 [System] After updating latest OTA , keyboard did not automatically show up on SIM Pin Screen
- https://bugzil.la/1228513 Turn on wifi and when it is searching aps, turn on "Airplane mode", the wifi will be toggled on/off alternately
- https://bugzil.la/1226307 [music] Fast-seeking to the end of the song skips over a song (goes from track 1 directly to 3)
- https://bugzil.la/1220812 After unlocking the device from the lockscreen there is a long pause until reaching the home screen
- https://bugzil.la/1235533 Voicemail, FDN and Call Forwarding is not available if user open call settings via dialer
  *We are unable to reproduce this issue with our US T-Mobile and AT&T SIM cards.
- https://bugzil.la/1235751 APP interface does not appear after taping home button
- https://bugzil.la/1172163 [Aries][Homescreen][OTA] Uninstalled apps are added back to the homescreen during an OTA System Update
- https://bugzil.la/1233243 [Aries] Zooming performance is poor and unresponsive in Camera Preview

=================================


Build Information (OTA from build 20151023103433):
Device: Aries 2.6
BuildID: 20160212150237
Gaia: 4f0e2a1a42a2d049b6fe8f4f095cdcdf0fd5465c
Gecko: 12bcf71bc5ad162c0c20195bb7c06f48b3c823b9
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 47.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Links:

Taskcluster:
https://tools.taskcluster.net/task-inspector/#JOMf3GtIS6qvpIwY-blRrA/0

Dogfood Test Logs:
https://docs.google.com/spreadsheets/d/111JUThDnk47kZvtiFq_DxFsAO6brrtWII6yRJ7LXUMs/edit#gid=1953402799

Moztrap Run:
https://moztrap.mozilla.org/runtests/run/8974/env/347/


~~~~~~~~~~~~~~~~~~~~~~~~~


The results for the test for a full FOTA : 
* 69/69 passing
* 0 reboots
* 0 crashes

=================================

Smoke Test Failures:

New:

- None reported

Existing:

- None reported

=================================

Severe Issues:

- https://bugzil.la/1247665 Unable to save an image from a webpage
- https://bugzil.la/1245670 [Aries] crash in pthread_mutex_lock_impl | pthread_rwlock_timedrdlock
- https://bugzil.la/1245633 Locking the phone while going into card view causes the SHB and the lockscreen to not appear
- https://bugzil.la/1243880 Opening multiple apps in a quick manner causes scroll and home button to break
- https://bugzil.la/1243159 [Aries] Start Tour button sometimes does not function to progress through tutorials after FTU
- https://bugzil.la/1234694 Sound settings reset to default after OTA update
- https://bugzil.la/1232857 Time remaining for battery is incorrect at times
- https://bugzil.la/1205809 [System] After updating latest OTA , keyboard did not automatically show up on SIM Pin Screen
- https://bugzil.la/1228513 Turn on wifi and when it is searching aps, turn on "Airplane mode", the wifi will be toggled on/off alternately
- https://bugzil.la/1226307 [music] Fast-seeking to the end of the song skips over a song (goes from track 1 directly to 3)
- https://bugzil.la/1220812 After unlocking the device from the lockscreen there is a long pause until reaching the home screen
- https://bugzil.la/1235533 Voicemail, FDN and Call Forwarding is not available if user open call settings via dialer
  *We are unable to reproduce this issue with our US T-Mobile and AT&T SIM cards.
- https://bugzil.la/1235751 APP interface does not appear after taping home button
- https://bugzil.la/1172163 [Aries][Homescreen][OTA] Uninstalled apps are added back to the homescreen during an OTA System Update
- https://bugzil.la/1233243 [Aries] Zooming performance is poor and unresponsive in Camera Preview

=================================


Build Information (FOTA from build 20151023103433):
Device: Aries 2.6
BuildID: 20160212150237
Gaia: 4f0e2a1a42a2d049b6fe8f4f095cdcdf0fd5465c
Gecko: 12bcf71bc5ad162c0c20195bb7c06f48b3c823b9
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 47.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:47.0) Gecko/47.0 Firefox/47.0

Links:

Taskcluster:
https://tools.taskcluster.net/task-inspector/#JOMf3GtIS6qvpIwY-blRrA/0

Dogfood Test Logs:
https://docs.google.com/spreadsheets/d/111JUThDnk47kZvtiFq_DxFsAO6brrtWII6yRJ7LXUMs/edit#gid=1953402799

Moztrap Run:
https://moztrap.mozilla.org/runtests/run/8973/env/347/

For a OTA :
Flags: needinfo?(nhirata.bugzilla)
Basically the BT broke because of some changes under gecko is my guess for OTA.  I could pull from earlier, though it would require testing time if I am recommended to take a different pull.

We're pretty much ready to go, just need to change the rules on Balrog and do a quick check to make sure the FOTA/OTA rules are setup correctly.
The build was pushed to the community with this patch in place.

We probably should get this pushed in just in case so that people don't accidentally make a build and try to push it with dogfood=1.

Wander, can you take a look at the patch and see if it's ok to push?
Attachment #8721498 - Flags: review?(wcosta) → review+
Flags: needinfo?(wcosta)
Flags: needinfo?(ktucker) → needinfo?(wkocher)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.