crash in shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_WaitCondVar | nsThread::ProcessNextEvent | NS_InvokeByIndex

RESOLVED WONTFIX

Status

()

--
critical
RESOLVED WONTFIX
3 years ago
18 days ago

People

(Reporter: khuey, Unassigned)

Tracking

(Depends on: 1 bug, {crash, hang})

unspecified
x86
Windows NT
crash, hang
Points:
---

Firefox Tracking Flags

(firefox47 affected, firefox48 affected, firefox-esr45 affected)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-6f6f1305-d593-4da2-9de2-f9f852160210.
=============================================================

The report doesn't tell us anything more than "someone is spinning the main thread from JS".  Any ideas on who it could be Yoric?
Flags: needinfo?(dteller)
I just know that there is a timeout at some point during quit-application.
Flags: needinfo?(dteller)
Can we fix it ...?
Flags: needinfo?(dteller)
Sure, once we find out what causes the timeout. But, as you mention, the report doesn't tell us anything. Could even be an add-on.
Flags: needinfo?(dteller)
Noting this is still a top crash on 45 and 46.0.1 release. It seems likely to be the case for upcoming versions too. Yoric, do you still think bug 1257424 might help diagnose what's going on?
Flags: needinfo?(dteller)

Updated

3 years ago
Keywords: crash
I think so, but I'm a bit out of the loop these days.

(apologies for the delay, I've been on PTO)
Flags: needinfo?(dteller)
Crash volume for signature 'shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_WaitCondVar | nsThread::ProcessNextEvent | NS_InvokeByIndex':
 - beta    (version 48): 4437 crashes from 2016-06-06.
 - release (version 47): 30560 crashes from 2016-05-31.
 - esr     (version 45): 4957 crashes from 2016-04-07.

Crash volume on the last 7 days:
             2016-07-21   2016-07-20   2016-07-19   2016-07-18   2016-07-17   2016-07-16   2016-07-15
 - beta             105          117          120          109           99          116          121
 - release          765          736          721          788          593          588          735
 - esr               88           94           89           99           19           22           84

Affected platform: Windows
status-firefox47: --- → affected
status-firefox48: --- → affected
status-firefox-esr45: --- → affected

Updated

2 years ago
Duplicate of this bug: 1186203

Updated

2 years ago
Crash Signature: [@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_WaitCondVar | nsThread::ProcessNextEvent | NS_InvokeByIndex] → [@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_WaitCondVar | nsThread::ProcessNextEvent | NS_InvokeByIndex] [@ shutdownhang | nsThread::ProcessNextEvent | NS_InvokeByIndex ] [@ shutdownhang | mozilla::CondVar::Wait | nsEventQueue::Ge…

Updated

2 years ago
Crash Signature: nsEventQueue::GetEvent | nsThread::ProcessNextEvent | NS_InvokeByIndex ] → nsEventQueue::GetEvent | nsThread::ProcessNextEvent | NS_InvokeByIndex ] [@ shutdownhang | mozilla::CondVar::Wait | nsEventQueue::GetEvent | nsThread::nsChainedEventQueue::GetEvent | nsThread::GetEvent | nsThread::ProcessNextEvent | NS_InvokeByIndex ]
Crash Signature: [@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_WaitCondVar | nsThread::ProcessNextEvent | NS_InvokeByIndex] [@ shutdownhang | nsThread::ProcessNextEvent | NS_InvokeByIndex ] [@ shutdownhang | mozilla::CondVar::Wait | → [@ shutdownhang | WaitForSingleObjectEx | WaitForSingleObject | PR_WaitCondVar | nsThread::ProcessNextEvent | NS_InvokeByIndex] [@ shutdownhang | nsThread::ProcessNextEvent | NS_InvokeByIndex ] [@ shutdownhang | mozilla::CondVar::Wait |
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Last Resolved: 18 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.