Can't control video play status at full-screen mode.

RESOLVED FIXED

Status

()

Firefox for Android
Screencasting
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Taguchi Fumihiko, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ft:conndevices], URL)

(Reporter)

Description

2 years ago
Playback following URL's video starts at full-screen mode automatically.
  http://headlines.yahoo.co.jp/videonews/nnn?a=20160217-00000015-nnn-soci

In this case, when pause/play/send video button is pressed, control panel doesn't work but it disappears.

Updated

2 years ago
tracking-fennec: --- → ?
(Reporter)

Comment 1

2 years ago
I used the latest nightly build and the add-on from https://addons.mozilla.org/en-US/android/addon/send-tab-to-tv/ .
Version: unspecified → 47 Branch

Updated

2 years ago
blocking-b2g: --- → 2.5+
This seems an general issue of the videocontrols.xml during device search. @margaret do you know better way to debug XBL? Setting breakpoint in WebIDE doesn't work for javascript in XBL and I couldn't find a way to print out debugging information. :(

I discovered that the video controller will start to work after you long pressing and dragging on the controller panel.

For end user they can still long press video area and trigger video sharing from the pop-up menu. It should not be a blocker for b2gv2.5.
blocking-b2g: 2.5+ → ---
Flags: needinfo?(margaret.leibovic)
Whiteboard: [ft:conndevices]

Comment 3

2 years ago
Debugging XBL is a pain, and I don't think it's well supported in our devtools :(

Let's ask jryans if he has any advice, but in the meantime I think you may be stuck with print debugging.
Flags: needinfo?(margaret.leibovic) → needinfo?(jryans)

Updated

2 years ago
tracking-fennec: ? → ---
(In reply to :Margaret Leibovic from comment #3)
> Debugging XBL is a pain, and I don't think it's well supported in our
> devtools :(
> 
> Let's ask jryans if he has any advice, but in the meantime I think you may
> be stuck with print debugging.

Well, it "should" work, but it's certainly not tested at all...  I am able to hit a breakpoint inside browser.xml on desktop, for example.

:schien, can you give more detailed STR so I can try it too?  I am not sure how to get to the feature we're discussing here.
Flags: needinfo?(jryans) → needinfo?(taguchi.fumihiko)
Flags: needinfo?(taguchi.fumihiko) → needinfo?(schien)
(In reply to J. Ryan Stinnett [:jryans] (use ni?) from comment #4)
> (In reply to :Margaret Leibovic from comment #3)
> > Debugging XBL is a pain, and I don't think it's well supported in our
> > devtools :(
> > 
> > Let's ask jryans if he has any advice, but in the meantime I think you may
> > be stuck with print debugging.
> 
> Well, it "should" work, but it's certainly not tested at all...  I am able
> to hit a breakpoint inside browser.xml on desktop, for example.
> 
> :schien, can you give more detailed STR so I can try it too?  I am not sure
> how to get to the feature we're discussing here.

I've filed bug 1250373 and provide detailed STR on that bug. I suspect it will happens on all XBL that creates multiple instances. It'll be great if @jryans can take a look at it!
Flags: needinfo?(schien)
(Reporter)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.