Closed Bug 1249000 Opened 4 years ago Closed 2 years ago

Using "load in sidebar" with bookmarks to about:reader URLs (pages in Reader mode) don't actually load in the sidebar

Categories

(Toolkit :: Reader Mode, defect, P5)

defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox44 --- affected
firefox45 --- affected
firefox46 --- affected
firefox47 --- affected

People

(Reporter: mboldan, Unassigned)

References

Details

(Keywords: ux-mode-error, Whiteboard: [reader-mode-firefox-integration])

[Affected versions]:
Firefox 47.0a1 (2016-02-16), Firefox 46.0a2 (2016-02-16), Firefox 45.0b6, Firefox 44.0.2

[Affected platforms]:
Mac OS X 10.10.5, Ubuntu 12.04 x64, Windows 10 x86

[Steps to reproduce]:
1. Launch Firefox.
2. Go to: (e.g.) http://bits.blogs.nytimes.com/2015/03/30/the-path-toward-tomorrows-internet/.
3. Click the "Enter Reader View" button from the Location Bar.
4. Bookmark this page and add it to Bookmark Toolbar.
5. Right click on the created bookmark and select the Properties button.
6. Enable 'Load this bookmark in the sidebar' and click the 'Save' button.
7. Click on the created bookmark.

[Expected result]:
The page is loaded in the bookmark sidebar.

[Actual result]:
The page is not loaded in the sidebar.

[Regression range]:
This is not a regression since the issue is reproducible on Firefox 39.0a1 (2015-03-04), build where the Reader view mode was introduced.

[Additional notes]:
This issue is reproducible with e10s enabled and disabled as well.
Has Regression Range: --- → no
Has STR: --- → yes
I guess Reader View mode is not ready for this mode.
Component: Bookmarks & History → Reader Mode
Keywords: ux-mode-error
Product: Firefox → Toolkit
Priority: -- → P5
Summary: The pages bookmarked in Reader View mode are not displayed in Bookmark sidebar → Using "load in sidebar" with bookmarks to about:reader URLs (pages in Reader mode) don't actually load in the sidebar
Whiteboard: [reader-mode-firefox-integration]
Has Regression Range: no → irrelevant
load is sidebar feature has been removed in bug 1452645.
Status: NEW → RESOLVED
Closed: 2 years ago
Depends on: 1452645
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.