If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Multiline text becomes single line after copy and paste

RESOLVED DUPLICATE of bug 1174452

Status

()

Core
Serializers
RESOLVED DUPLICATE of bug 1174452
2 years ago
2 years ago

People

(Reporter: marina9568, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.109 Safari/537.36

Steps to reproduce:

I've created div with style "white-space: pre-wrap" in which I've added text with line breaks '\n' - 'one\ntwo\nthree\nfour'.
I've got multiline result.
You can see it in fiddle:
https://jsfiddle.net/s83rjsj8/
Copy this multiline result and paste into text editor (for example Notepad).


Actual results:

If I copy text in Firefox and paste to Notepad I'm getting inline text: one two three four


Expected results:

I've used other browsers such as Chrome or EDGE and I'm getting desired result - multiline text:
one
two
three
four

Comment 1

2 years ago
Dupe of bug 1174452, I think.
Component: Untriaged → Serializers
(In reply to Loic from comment #1)
> Dupe of bug 1174452, I think.

Looks like it. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1174452
You need to log in before you can comment on or make changes to this bug.