Input stops working in gmail from time to time.

RESOLVED WORKSFORME

Status

()

Core
Editor
--
major
RESOLVED WORKSFORME
2 years ago
a year ago

People

(Reporter: mbest, Unassigned)

Tracking

(Blocks: 1 bug, {top100})

47 Branch
x86_64
Windows 10
top100
Points:
---

Firefox Tracking Flags

(e10s-, platform-rel +, firefox47 affected)

Details

(Whiteboard: btpp-follow-up-2016-03-10 [platform-rel-Google] [platform-rel-Gmail][platform-rel-GoogleDocs], URL)

(Reporter)

Description

2 years ago
Every now an then, I experiences input boxes stop accepting text.  If I restart the browser everything is fine.  It's hard to replicate.  Google docs and gmail are where I experience this the most.

I am using nightly 64 bit with e10s turned on.
I think those sites use <div contenteditable> rather than form controls (<input> or <textarea>).
Can you check? (using devtools)
Flags: needinfo?(mbest)
(Reporter)

Comment 2

2 years ago
Looks like <div contenteditable>

<div tabindex="1" style="direction: ltr; min-height: 85px;" role="textbox" g_editable="true" id=":3mg" class="Am Al editable LW-avf" hidefocus="true" aria-label="Message Body" contenteditable="true"><br></div>
Flags: needinfo?(mbest)
Thanks, this is probably an Editor / e10s issue then.  Perhaps it would help narrow it down
if you run with e10s turned off for a while and see if the problem disappears?
Component: Layout: Form Controls → Editor
Given that these are top100 sites, this should probably block shipping e10s.
Severity: normal → major
tracking-e10s: --- → ?
Keywords: top100
I'll try to find reliable STR's and whether it's worse on e10s or not.
Flags: needinfo?(mbest)
Sorry about that Martin. I meant to NI myself.
Flags: needinfo?(mbest) → needinfo?(twalker)
Whiteboard: btpp-active btpp-follow-up-2016-03-03
(Reporter)

Comment 7

2 years ago
NP.  Again, wish I had better duplication steps.  As far as I can tell so far it happens randomly and fairly infrequently.  Have not been able to find a repro case yet.  I have seen it happen with and without e10s turned on.
Whiteboard: btpp-active btpp-follow-up-2016-03-03 → btpp-follow-up-2016-03-10

Comment 8

2 years ago
per comment 7, not e10s specific.
tracking-e10s: ? → -

Updated

2 years ago
Flags: needinfo?(twalker)
Whiteboard: btpp-follow-up-2016-03-10 → btpp-follow-up-2016-03-10 [platform-rel-Google] [platform-rel-Gmail]

Updated

2 years ago
platform-rel: --- → ?
Whiteboard: btpp-follow-up-2016-03-10 [platform-rel-Google] [platform-rel-Gmail] → btpp-follow-up-2016-03-10 [platform-rel-Google] [platform-rel-Gmail][platform-rel-GoogleDocs]

Updated

2 years ago
Blocks: 1286366
platform-rel: ? → +
Are you still experiencing this, Martin?
Flags: needinfo?(mbest)

Updated

2 years ago
Flags: needinfo?(ayg)
(Reporter)

Comment 10

2 years ago
I have not run into this lately.  I have been using nightly pretty aggressively and have not run into this in some time.

Martin
Flags: needinfo?(mbest)
I don't see anything to do here without more specific steps to reproduce, especially given comment 10.
Flags: needinfo?(ayg)
Let's re-open this if it starts happening again.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.