(Re-)Add link to add-on review tools

VERIFIED FIXED in 2016-02-23

Status

Marketplace
Consumer Pages
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: eviljeff, Assigned: eviljeff)

Tracking

Avenir
2016-02-23
Points:
---

Details

(Assignee)

Description

2 years ago
https://github.com/mozilla/fireplace/commit/1c325f8263744f2db6da56007248321761cb8d99 removed the only FxOS Add-ons tool link visible on FxOS/mobile, and we need to access the tool to install the add-on.
(Assignee)

Comment 2

2 years ago
https://github.com/mozilla/fireplace/commit/06208929a4eca0a01352002c8769e5323e0b65d9
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2016-02-23

Comment 3

2 years ago
The link was successfully added in More menu on FF OS 2.5 (Flame).
Please see the screenshot: http://screencast.com/t/1QPPf1YT

But, I am encountering an old issue - https://bugzilla.mozilla.org/show_bug.cgi?id=1220101 - it is reproducing when accessing this new link and coming back to MP homepage, as follows:

1. Tap "More"-"Add-ons Tools"
2. Tap the MP-logo from Content Tools page

Results:
1. "Add-ons" button from the navigation menu and "Add-on" li "More" menu are not listed anymore
2. The new option (Add-on Tools) from "More" menu is not listed anymore.

This small "issue" is NOT reproducing if we go in :debug page and tap the "Always show Firefox OS Add-ons", but this new option is available not only for reviewers but for normal users also, so I suppose Comment 6 from Bug 1220101 does not apply.

Reopening until further notice.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This is because the link added doesn't specify a target, so when clicked on from the app, it loads an external page (the content tools) in the chrome-less app. Then, you're basically in a chrome-less browser, looking at web pages, so clicking on the MP-logo just sends you to the website, which acts like if you went to marketplace via the browser (won't show add-ons in the nav, for example).

NI Davor, because I'm not clear if we're using the rel attribute for anything (I see that Lookup Tool, for example, uses "external" for rel, but I don't think we use it).
Flags: needinfo?(dspasovski)
You're right rel=external might address this since the link is relative: https://github.com/mozilla/fireplace/commit/0f44b6a
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Flags: needinfo?(dspasovski)
Resolution: --- → FIXED

Comment 6

2 years ago
Still reproducing.
Verified on FF OS 2.5 and 2.6(Flame) using MP-dev app.
Don't know if there is something that can be done here and if this should be reopened or not.
Davor?
Flags: needinfo?(dspasovski)
Unless we are specifically doing something to anchors with rel=external, I don't think it will change unless we specify a target attribute.

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
We are doing something but it's not the right thing it seems (we're bypassing the internal routes) so added a _blank also. https://github.com/mozilla/fireplace/commit/9d10a81
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Flags: needinfo?(dspasovski)
Resolution: --- → FIXED

Comment 9

2 years ago
I am still able to reproduce this issue as described in comment #3
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
That's correct. But if you look at what's open, you should see that you have the app open on marketplace, and the browser open on marketplace (because the browser is what opened when you clicked on "Addon Tools").

If that is the case, that's correct and as far as this fix is going to go.
Flags: needinfo?(vcarciu)

Updated

2 years ago
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED

Comment 11

2 years ago
(In reply to David Durst [:ddurst] from comment #10)
> That's correct. But if you look at what's open, you should see that you have
> the app open on marketplace, and the browser open on marketplace (because
> the browser is what opened when you clicked on "Addon Tools").
> 
> If that is the case, that's correct and as far as this fix is going to go.

Yes, that is what happens. Please see the screenshot: http://screencast.com/t/CuZQ9YYC
Closing bug.
Status: RESOLVED → VERIFIED
Flags: needinfo?(vcarciu)
You need to log in before you can comment on or make changes to this bug.