Remove support for "-webkit-appearance" for now, since in practice it works differently from "-moz-appearance"

RESOLVED FIXED in Firefox 47

Status

()

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: dholbert, Assigned: dholbert)

Tracking

Trunk
mozilla47
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
i-meant-bug-1248975
As noted in bug 1236506 and bug 605985, "-moz-appearance:none" doesn't really work the same way "-webkit-appearance:none" does (at least, not for checkboxes & radio buttons).

So, for sites that are conscientious and use feature-detection to sniff for "-webkit-appearance" support (and provide fallback when it's not), our current aliasing behavior (on Nightly) moves us from working fallback code to not-working -webkit-appearance dependent code. (where "not working" means "checkbox maybe still shows up but it looks out of place because it's not themed like the rest of the site")

This is a usability regression. See screenshots on bug 1236506 for an example of this.

We should probably hold off on shipping "-webkit-appearance" as an alias, at least until we've got a better plan for bug 605985.
(Assignee)

Updated

3 years ago
Summary: Remove support for "-webkit-appearance" for now, since in practice it's not a strict alias for "-moz-appearance" → Remove support for "-webkit-appearance" for now, since in practice works differently from "-moz-appearance"
(Assignee)

Updated

3 years ago
Blocks: 1248975
Depends on: 837211
(Assignee)

Comment 1

3 years ago
Created attachment 8720508 [details] [diff] [review]
fix v1
Attachment #8720508 - Flags: review?(cam)
(Assignee)

Updated

3 years ago
Assignee: nobody → dholbert
Status: NEW → ASSIGNED
(Assignee)

Updated

3 years ago
Summary: Remove support for "-webkit-appearance" for now, since in practice works differently from "-moz-appearance" → Remove support for "-webkit-appearance" for now, since in practice it works differently from "-moz-appearance"
(Assignee)

Comment 2

3 years ago
I believe this particular alias wasn't actually buying us too much in terms of site-fixing, which is why I'm not too concerned with removing it.

I think Mike is on board with removing it, too, per bug 605985 comment 42 ("We should probably consider removing the -webkit-appearance alias until we understand all the issues (and ideally match on behavior).")
Attachment #8720508 - Flags: review?(cam) → review+
Yep, I think the differences between -moz- and -webkit- are too big for an alias to get us much. Expect bugs to follow once we have a better understanding of how people are using this in the wild (akin to Bug 605985).

Comment 6

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/a8431b350f2b
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox47: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1248975
(Assignee)

Updated

3 years ago
Blocks: 1259345
Is there already a bug for reimplementing -webkit-appearance once bug 605985 is fixed?

Sebastian
Flags: needinfo?(dholbert)
(Assignee)

Updated

2 years ago
Blocks: 1302104
(Assignee)

Comment 9

2 years ago
Not that I'm aware of. I filed bug 1302104 on that.
Flags: needinfo?(dholbert)
You need to log in before you can comment on or make changes to this bug.