If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Missing icons, rectangles on web pages, Windows 10, Fx 34b1 up to 47nightly

RESOLVED DUPLICATE of bug 1228799

Status

()

Core
Layout: Text
RESOLVED DUPLICATE of bug 1228799
2 years ago
2 years ago

People

(Reporter: a8092719, Unassigned)

Tracking

({fonts})

47 Branch
x86_64
Windows 10
fonts
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8720584 [details]
Firefox 34 - 47 visual bug rectangles.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160215141016

Steps to reproduce:

RECTANGLES - squares (missing icons, missing arrows, not fonts) - see picture

To best understand this visual bug is to check my attached picture, where I provided tests of the regression window and I think I found the origin of the first faulty version, which appears to be Firefox 34 beta 1. {link  1} Before that, Firefox 33b9 works OK. I noticed this bug only recently, after I installed Win10 on this same laptop, it has probably never appeared on Win7 at all. Im positive it has something to do with Winsows 10 or the new nVidia driver.

Ive done all these tests (except todays Nightly version) on fresh new profiles, using profile manager, no addons. I can reproduce every time. About 1/3rd of all pages i browse are affected, its very widespread. Also happens on mozilla.org everywhere.

This bug doesn't appear on my other desktop PC, with Windows 7 Ultimate SP1 32bit US-en (no updates, 10 year old nVidia card, new nVidia driver), no-matter what I tried,  everything works OK there. Thats why i think its only happening on Windows 10.

1. MUST USE  Windows 10 Pro 64bit US-en version 1511 (Fresh installation, I did not install any Windows updates, I disabled the update service)

2. Preferably use an older laptop with nvidia card with nvidia driver from october 2015 
(my specs: graphic card: NVIDIA GeForce 310M, driver: NVIDIA date:13.10.2015     version: 9.18.13.4192)

3. OPTIONAL: I disabled Windows Firewall (Im using Comodo firewall where I set "Web Browser" when Firefox attempts to connect) Saying this just because in another bugzilla thread (789788),  Jonathan Kew (:jfkthame) said it  could have something to do with Windows 10 firewall, but I have it off.

4. Install newest Nightly Firefox (for example 47.0a1 (2016-02-17)), with fresh profile, no changes needed

5. Open one of the affected websites, example:    https://www.expedia.com/  



The bug could be relevant to:
1) A change in Firefox code between Firefox 33 beta 9 and Firefox 34 beta 1.
2) Operating system - Win10 doesn't work, Win7 works OK
3) Graphics driver (both im using are nVidia drivers of different dates, one desktop, one laptop)


Notes: 
Im 100% positive it can be fixed just by changing Firefox code, no driver update is necessary.
The bug is completely independent of these things: Language interface of Firefox, Electrolysis off/on, plugins enabled/disabled, addons installed, setting "allow pages to use their own fonts", firewall settings, antivirus (its off, yet when I use Firefox 33.0.3 on the same laptop, it works flawlessly)

This bug also affects icons in some addons, I noticed it in uBlock Origin {2}, where the UI is completely broken- icons replaced by rectangles (on other PC with Win7 it works OK). The developer knows about it, he pointed to Bug 789788 but thats now resolved fixed. The bug is also present in tor browser, which is based on Firefox.


If you need more info, or if you have builds I could try, let me know.


{1}   https://ftp.mozilla.org/pub/firefox/releases/34.0b1/win32/en-GB/Firefox%20Setup%2034.0b1.exe
{2}   https://addons.mozilla.org/en-US/firefox/addon/ublock-origin/


Actual results:

See picture 

http://113.imagebam.com/download/KpFRyMUTVhl5LzLnDIvKJw/46586/465858497/Firefox%2034%20bug%20rectangles.png

1) Seven icons on the left disappeared, weird rectangles with random characters appeared instead of icons. For example, airplane icon changed into rectangle with "E0IF" 
2) All 4 little arrows in the upper part disappeared. By the way, its usually arrows on other pages that disappear very often.
3) The closing X button in the upper right corner disappeared, changed into a rectangle.


Expected results:

All icons (airplane, hotel, car...), arrows and the X button should render correctly, not as weird rectangles instead.
(Reporter)

Updated

2 years ago
Has Regression Range: --- → yes
Keywords: icon, platform, regression, ux-consistency
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Updated

2 years ago
Keywords: ux-consistency → ux-visual-hierarchy
(Reporter)

Updated

2 years ago
Keywords: ux-visual-hierarchy → ux-consistency

Comment 1

2 years ago
Can you check your Windows Firewall service is started? Bug 1228799.
Component: Untriaged → Layout: Text
Keywords: icon, platform, regression, ux-consistency → fonts
Product: Firefox → Core

Comment 2

2 years ago
And, can you post the meassges of Web Console (F12 - Console)?
Flags: needinfo?(a8092719)
(Reporter)

Comment 3

2 years ago
Created attachment 8720797 [details]
Firefox 47.0a1 console report - missing icons.png
Flags: needinfo?(a8092719)
(Reporter)

Comment 4

2 years ago
Created attachment 8720802 [details]
OLD Firefox 33b9 console report - icons OK.png
(Reporter)

Comment 5

2 years ago
Created attachment 8720804 [details]
Windows 10 services - firewall disabled.png

Windows firewall service is disabled from the day I installed Windows 10. I disabled more of Windows services that I found to be bloating my pc, if you want, I can screenshot all services. Im anti-MS haha. 

Please note that when I try old Firefox 33 on this same laptop and same firewall etc, the icons display normally. From Fx 34 and up, it doesnt work.

Here is the log from Web Console. I took screenshots of services and console in both 47nightly and 33 beta9 as well.




Console log from Firefox Nightly 47.0a1 (2016-02-17):

downloadable font: not usable by platform (font-family: "UITKIcons" style:normal weight:normal stretch:normal src index:2) source: https://a.travel-assets.com/uitoolkit/2-53/d9ae75969cea080a99e6885f8f66412012e01ae1/core/fonts/UITKIcons.woff exp-responsive.css:1:6110
downloadable font: not usable by platform (font-family: "UITKIcons" style:normal weight:normal stretch:normal src index:3) source: https://a.travel-assets.com/uitoolkit/2-53/d9ae75969cea080a99e6885f8f66412012e01ae1/core/fonts/UITKIcons.ttf exp-responsive.css:1:6110
Use of getPreventDefault() is deprecated.  Use defaultPrevented instead. uitk-jquery-jstemplate-bundle-min.js:2:40534
Ads client scripts were previously loaded expads.js:1:9582
RTCIceServer.url is deprecated! Use urls instead. <unknown>
'mozHidden' and 'mozVisibilityState' are deprecated.  Please use the unprefixed 'hidden' and 'visibilityState' instead. pubads_impl_80.js:122:114
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] tags.bkrtx.com
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] js-sec.casalemedia.com
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] r.casalemedia.com
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] as-sec.casalemedia.com
This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] cdn-sec.optmd.com

Comment 6

2 years ago
It is the same issue. Let's focus on it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1228799
You need to log in before you can comment on or make changes to this bug.