Closed Bug 1249297 Opened 5 years ago Closed 5 years ago

Remove "double-click to open comment" feature

Categories

(MozReview Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mconley, Unassigned)

References

()

Details

Bug 1246769 made this optional, and on by default.

karlt wrote in bug 1246769 comment 7:

I wonder whether this should default to off.
I get the feeling more people now are just quoting one line in review comments instead of the code that they are commenting on.

Might want mcote or other MozReview core folk to weigh in here, but it's a pretty simple flip if we decide to change it.
Based on bug 1246769 comment 10, re-purposing this bug to remove the double-click to add a comment feature altogether.
Summary: Make "double-click to open comment" off by default → Remove "double-click to open comment" feature
Blocks: 1239905
Cc'ing :ted who originally filed bug 1101601 just so he knows what's up.
See Also: → 1101601
:( I use this, and would have preferred keeping it. I would have been fine with it being off by default.
Would we be okay for keeping it preffed off by default, but available for the people who want to use it, like botond?

Alternatively, a quick and easy WebExtension could be built with this capability.
Flags: needinfo?(mcote)
Duplicate of this bug: 1239905
Product: Developer Services → MozReview
Talked about this in #mozreview with smacleod. I'll build a quick-and-dirty WebExtension for the folks who want the double-click feature.

Backed out the feature here:

https://hg.mozilla.org/hgcustom/version-control-tools/rev/144f62196085
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Flags: needinfo?(mcote)
This has been deployed to production.
You need to log in before you can comment on or make changes to this bug.