Closed Bug 1249321 Opened 4 years ago Closed 4 years ago

Drag Dropping from Chrome into Firefox creates garbled text and chinese characters.

Categories

(Core :: Drag and Drop, defect)

44 Branch
x86_64
Windows 8.1
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 586587

People

(Reporter: kaboom05, Unassigned)

Details

(Keywords: html5, regression)

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

From any chrome page I.E. Wikipedia English is a good candidate select a section of text. Drag and drop that into a content editable in Firefox.

Notice the result is a bunch of garbled Chinese characters.

Note if you look at the drag drop event the getData('text/html') also returns these Chinese characters where getData('text/plain') seems to give you correct text without all the formatting.

This bug is related to:
https://bugzilla.mozilla.org/show_bug.cgi?id=900414

It is present in Firefox 44.0.2


Actual results:

Garbled Chinese characters.


Expected results:

Dropped html text from chrome.
Also related to:

https://bugzilla.mozilla.org/show_bug.cgi?id=1050566
Keywords: html5, regression
OS: Unspecified → Windows 8.1
Hardware: Unspecified → x86_64
Are you able to reproduce the issue with a clean profile?
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Yes
Component: Untriaged → Drag and Drop
Product: Firefox → Core
It seems this was fixed by bug 586587 which landed after 44 branched.

Can you please try to reproduce in Nightly and then again in Beta?
Flags: needinfo?(kaboom05)
Firefox 46a2 (Firefox Developer Edition) has this bug fixed.

Do you know where I can obtain a copy of Firefox 45 Beta so I can retest this on the next outgoing version?
Flags: needinfo?(kaboom05)
Thanks for verifying in devedition!

You can download beta builds here: https://www.mozilla.org/en-US/firefox/channel/#beta

At this point I'm just going to mark this as a dupe of the bug where this was fixed.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 586587
You need to log in before you can comment on or make changes to this bug.