Closed Bug 1249374 Opened 5 years ago Closed 5 years ago

Deleting the entire content of contenteditable keeps a <br>

Categories

(Core :: DOM: Editor, defect)

47 Branch
x86_64
Windows 10
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 414223

People

(Reporter: cyril.auburtin, Unassigned)

Details

(Keywords: testcase)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160217030229

Steps to reproduce:

demo: http://jsfiddle.net/crl/xzcv1kxb/

type text in the contenteditable, then delete it all (either backKey, or ctrl+a, suppr, ...)

a <br> will remain in the contenteditable, it prevents a css placeholder like :empty  to work


Actual results:

a <br> tag is always there after trying to make the contenteditable empty


Expected results:

should be empty
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Component: Untriaged → Editor
Keywords: testcase
Product: Firefox → Core
Unfortunately I think bug 414223 comment 13 still stands :(
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414223
This is an issue I would love to see fixed. I can make a workaround, but it's cases like this that make cross-platform contenteditable text editing so difficult.
In version 58.0.1 (64 bity) 
This issue still occurs

That issue still happens in 64.0 (64-bit). Any chance to have it resolved?

Flags: needinfo?(m_kato)

(In reply to rudiyivan from comment #6)

That issue still happens in 64.0 (64-bit). Any chance to have it resolved?

We will continue this to bug 1513303.

Flags: needinfo?(m_kato)
You need to log in before you can comment on or make changes to this bug.