Failure summary comes up empty on first job clicked

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: wlach, Assigned: wlach)

Tracking

Details

Attachments

(1 attachment)

Noticed this on prod deploy. This is due to an oversight in bug 1239779
Blocks: 1239779
Created attachment 8720962 [details] [review]
PR

Can you give this a fast review :camd? The problem is that there's a race condition with displaying the failure summary: the failure summary has update logic which is only triggered when (1) the tab is first loaded or (2) the user explicitly switches to it, and the patch in bug 1239779 made it so we only switch to the failure summary *after* we've loaded the tab for the first time.

There are a bunch of things we should do to clean this up, but this fixes the immediate problems.
Attachment #8720962 - Flags: review?(cdawson)

Comment 2

3 years ago
Commit pushed to master at https://github.com/mozilla/treeherder

https://github.com/mozilla/treeherder/commit/d551bed6ad15c5a6599b5e4188c69619b5a4f115
Bug 1249395 - Fix issue where failure panel wouldn't display on first load
I merged this in because I didn't think we wanted to wait on it, but I'd still appreciate a review.
Comment on attachment 8720962 [details] [review]
PR

This solution looks good to me.  Improves efficiency, too, by saving the ajax call if the job is not a success.  Thanks for fixing this.  :)
Attachment #8720962 - Flags: review?(cdawson) → review+

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Priority: -- → P1
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.