bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

sync setup fails with “Invalid email address” message

RESOLVED DUPLICATE of bug 1022319

Status

SeaMonkey
Sync UI
RESOLVED DUPLICATE of bug 1022319
2 years ago
6 months ago

People

(Reporter: romko.b.m, Unassigned)

Tracking

SeaMonkey 2.39 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8720952 [details]
Capture_017.jpg

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:42.0) Gecko/20100101 Firefox/42.0 SeaMonkey/2.39
Build ID: 20151103191810

Steps to reproduce:

Menu → Tools → Set Up Sync → Create a New Account → Email Address → Invalid email address  


Actual results:

When I start typing in my email address after three keystrokes I immediately get “Invalid email address” message.

Comment 1

2 years ago
This does not seem to be a problem on Linux 64-bit.
(Reporter)

Comment 2

2 years ago
(In reply to Michael Pagano from comment #1)
> This does not seem to be a problem on Linux 64-bit.
Was the Sync service established at last? If yes, than what does this mean??!:
http://www.seamonkey-project.org/doc/sync
SeaMonkey Sync
Attention! Starting with Firefox 29 (SeaMonkey 2.26), it is not possible anymore to set up legacy Sync accounts as described below. The new Sync back-end, which uses Firefox Accounts, is not supported by SeaMonkey yet. If you want to use Sync with both Firefox and SeaMonkey, you will need to use an older version (e.g. Firefox 28 or SeaMonkey 2.25) to do the setup. Once Sync setup is complete, you may go back to using the current versions.

Comment 3

2 years ago
I confirm, this does happen, in:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0 SeaMonkey/2.44a1

One is not prevented from continuing to enter the complete email address, but known good email addresses resulted in "Unknown Error" instead of "Invalid email address".

Probably the meanings of errors should be fleshed out so the user can take appropriate actions, and if sync is not available yet the UI should make that clear somehow.

Comment 4

2 years ago
(In reply to benl from comment #3)
> I confirm, this does happen, in:
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
> SeaMonkey/2.44a1
> 
> One is not prevented from continuing to enter the complete email address,
> but known good email addresses resulted in "Unknown Error" instead of
> "Invalid email address".
> 
> Probably the meanings of errors should be fleshed out so the user can take
> appropriate actions, and if sync is not available yet the UI should make
> that clear somehow.

It appears to be strictly a Windows issue, then.
This needs to be taken care of in Bug 1022319.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1022319
You need to log in before you can comment on or make changes to this bug.