ServiceWorker registration not updated on disk properly

RESOLVED DUPLICATE of bug 1246319

Status

()

Core
DOM: Service Workers
RESOLVED DUPLICATE of bug 1246319
2 years ago
2 years ago

People

(Reporter: bkelly, Assigned: bkelly)

Tracking

45 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
+++ This bug was initially created as a clone of Bug #1246319 +++

This is a regression introduced in bug 1246319.  It results in empty about:serviceworker entries:

    Scope: https://people.mozilla.org/~ewong2/push-notification-test/
    Script Spec:
    Current Worker URL:
    Active Cache Name:
    Waiting Cache Name:
    Push Endpoint: {"endpoint":"https://updates.push.services.mozilla.com/push/gAAAAABWxj9DXmUQmqJST_jm-XuuJE_rdwxkzxJOwZWK-PefDVkvyEeninj9SzLsZQafAScZWEym_OJmel-5ErtML2BLlJhqdJSwfXdMLr5CY6zhpH6__suZEL3L5F7Ca-7sK6AkAPpUBR70O7X7SgvF4K9hLXuRXTBhykWIJQxW6jqzdT9taMc=","pushCount":0,"lastPush":0,"quota":16}
(Assignee)

Comment 1

2 years ago
Created attachment 8721003 [details] [diff] [review]
Fix service worker registry update. r=baku
Assignee: nobody → bkelly
Status: NEW → ASSIGNED
Attachment #8721003 - Flags: review?(amarchesini)
(Assignee)

Comment 2

2 years ago
I ended up doing this as a follow-up in bug 1246319 since it was in the middle of uplifts.
No longer blocks: 1246319
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1246319
Attachment #8721003 - Flags: review?(amarchesini) → review+
You need to log in before you can comment on or make changes to this bug.